Go Down

Topic: Reinstalling: "Could not read default setttings" (Read 1 time) previous topic - next topic

limn

I've opened up my arduino box of tricks having not used it for year or so, with the intention of using it again with Max/MSP..

I had deleted the arduino application previously (i think i was running perhaps Arduino something-teen last time it worked), and have just reinstalled using Arduino 22, but while on opening the application get the error "Could not read default settings, Please reinstall arduino"

I've tried reinstalling and re-downloading to no effect. Google and the forum searches yields little on the error, but looking at the code it seems to be related to a missing preferences.txt, although I gather this is usually generated the first time Arduino is run, which is exactly the point where this error is generated..

Could it perhaps be something like AppTrap having deleted some files that arduino now expects to be there?


any help would be very much appreciated!

I'm running Mac OS X 10.6.7 on a 2007 mac, "java -version" in terminal shows the following:

java version "1.6.0_24"
Java(TM) SE Runtime Environment (build 1.6.0_24-b07-334-10M3326)
Java HotSpot(TM) Client VM (build 19.1-b02-334, mixed mode)

Go Up