Go Down

Topic: Problema c/ sensor dht22 (Read 396 times) previous topic - next topic

99fernando

Olá  ;)
Estou tendo um problema com o sensor DHT22, estava fazendo alguns testes com meu módulo relé(fonte externa) quando ligo e desligo um solenoide ou qualquer outra coisa varias vezes seguidas dps de um tempo o DHT22 para de funcionar ai só desligando a fonte nem resetando o arduino volta o que poderia ser ?

alkuentrus

No outro dia tive uns stresses com isso. Era problema da fonte de alimentação. Qual o arduino, qual a fonte?
Se estiveres a usar fonte externa para alimentar os relés, tens de verificar a massa comum.

99fernando

#2
Mar 30, 2019, 11:19 pm Last Edit: Mar 30, 2019, 11:22 pm by 99fernando
Qual o arduino, qual a fonte?
Arduino mega 2560 r3 mas não é original

mais ou menos assim(sem o jumper JD-VCC VCC): aqui

(a mesma fonte alimenta o Arduino mas para o módulo relé passa pelo step-down a mesma coisa acontece alimentando pelo USB do pc)

Tentei interligando o GND da fonte, do arduino e do módulo(com o jumper), mas da na mesma trabalha um pouco o sensor DHT22 para de funcionar as vezes até trava o arduino não tem uma ordem especifica as vezes funciona mais tempo as vezes logo para... não sei o que fazer

FONTE 12v 4A 48W: aqui

Step-down: aqui

alkuentrus

Não consegues arranjar outro sensor para testar?
Queres meter aqui o código para a gente ver?

99fernando

Eu acho que é questão de hardware esse código bem simples e já assim trava ou para de funcionar o arduino.
Se acionar outros reles sem um motor ou solenoide não acontece isso então tenho quase certeza que é algum ruido, mas como isso acontece sendo que o módulo tem fotoacoplador a unica ligação é o mesmo cabo 220v e o que está na imagem sinceramente não sei o que fazer já testei outras duas fontes o arduino reinicia ou o sensor não funciona também .

Code: [Select]
#include <Adafruit_Sensor.h>
#include <DHT.h>
//lcd
#include <Adafruit_GFX.h>
#include <Adafruit_PCD8544.h>

#define DHTPIN 2
#define DHTTYPE    DHT22

Adafruit_PCD8544 display = Adafruit_PCD8544(6, 5, 4, 3, 7);//lcd
DHT dht(DHTPIN, DHTTYPE);
uint32_t delayMS;

void setup() {
  pinMode(45, OUTPUT);//rele
  pinMode(43, OUTPUT);

  Serial.begin(9600);

  dht.begin();
  display.begin();
  display.setContrast(50);
  display.clearDisplay();   // clears the screen and buffer
}
int count;
void loop() {
  // Delay between measurements.
  count++;
  digitalWrite(45, LOW);
  digitalWrite(43, LOW);
  delay(1000);
  digitalWrite(45, HIGH);
  digitalWrite(43, HIGH);
  delay(1000);

  float h = dht.readHumidity();
  float t = dht.readTemperature(false);

  Serial.print("count: ");
  Serial.print(count);

  Serial.print(" temperature: ");
  Serial.println(t);

  //======================
  display.setTextColor(BLACK);
  display.setTextColor(WHITE, BLACK);
  display.setTextSize(1);
  //------------------- 
  display.setCursor(0,0);
  display.print("temp: ");
  display.print(t);
  //-------------------
  display.setCursor(0,16);
  display.print("count: ");
  display.print(count);
  display.display();
}

99fernando

#5
Mar 31, 2019, 10:35 pm Last Edit: Mar 31, 2019, 10:39 pm by 99fernando
Resolvi colocando um capacitor de poliéster em paralelo com a válvula solenoide 220v,
retirei de uma fonte chaveada igual o da imagem só que ao invés de 104k é 224k:




Gostaria de saber se não tem problema usa-lo a longo prazo ?

alkuentrus

Não tem problema. Esse condensador está a fazer uma espécie de filtragem básica. O que acontece basicamente é que quando mandas desligar a válvula, esse condensador segura-a ligada até descarregar (uns parcos milissegundos). Ainda bem que resolveste. Bons projectos!

alkuentrus

... Opá, voltei porque estive a pensar e não faz muito sentido... A válvula 220V está electricamente isolada do resto do circuito, uma vez que está ligada apenas aos relés azuis (mete aí uma foto ou um esquema do que fizeste sff)... Podes voltar a ter problemas na mesma...

99fernando

#8
Apr 01, 2019, 12:36 am Last Edit: Apr 01, 2019, 12:37 am by 99fernando
Então esta é a unica ligação, não sei fazer esquema elétrico:
o único capacitor está na imagem


link

alkuentrus

Pois, talvez o ligar/desligar da valvula fizesse ruído electrónico que não fosse devidamente filtrado pela fonte que 220V/12V e assim, deve estar resolvido.
Boa, estás safo :)

99fernando

#10
Apr 04, 2019, 12:52 am Last Edit: Apr 04, 2019, 10:22 am by 99fernando
Colocando perto do solenoide funciona como já dito mas como existe uma taxa de 90% de umidade talvez venha a estragar o capacitor então, tentei colocar em paralelo com o rele igual na imagem só que sem o resistor, mas ai ele fechava contato e ligava o solenoide mesmo com o rele desligado, se eu colocar um resistor em conjunto com o capacitor não irá fechar contato? Se sim,
Qual resistor devo colocar ?


Go Up