Go Down

Topic: Are there things in supporting libraries that need to be changed? (Read 130 times) previous topic - next topic

This is the program: github.com/debsahu/ESP-MQTT-AWS-IoT-Core

I am trying to get the program to work with an esp8266 so I'm using this one:
C:\Users\Adam\Documents\Arduino\ESP-MQTT-AWS-IoT-Core-master\ESP-MQTT-AWS-IoT-Core-master\Arduino\MQTT

Are there things that need to be changed in the supporting libraries? All I've changed is the secrets.h:

Code: [Select]
Arduino: 1.8.4 (Windows 7), Board: "NodeMCU 0.9 (ESP-12 Module), 80 MHz, 4M (1M SPIFFS), v2 Lower Memory, Disabled, None, Only Sketch, 115200"

MQTT:19: error: #error "Install ArduinoJson v6.7.0-beta"

 #error "Install ArduinoJson v6.7.0-beta"

  ^

exit status 1
#error "Install ArduinoJson v6.7.0-beta"

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.


After commenting out the code below, many more errors occurred:
Code: [Select]
#if !(ARDUINOJSON_VERSION_MAJOR == 6 and ARDUINOJSON_VERSION_MINOR == 7)
#error "Install ArduinoJson v6.7.0-beta"
#endif


I don't understand why this is happening. I downloaded the JSON library:

groundFungus




Go Up