Go Down

Topic: No response AT-Commands SIM900A (Read 895 times) previous topic - next topic


Feb 16, 2019, 01:10 pm Last Edit: Feb 16, 2019, 01:13 pm by pulung_ps Reason: Retry to attach file
I need some helps
I have a problem with my SIM900A module. It can't communicate the at-commands.
The wires :
VCC on gsm module ---> +5V/2~3Amp
GND on gsm module ---> GND

RX on gsm module ---> TX arduino (pin 1)
TX in gsm module ---> RX arduino (pin 0)
GND gsm module ---> GND arduino

I have tried with simple code and empty code to search the baudrate
But I didnt see the response at command in serial monitor

Then I tried with FTDI to PuTTy software serial
The wires :
VCC on gsm module ---> +5V/2~3Amp
GND on gsm module ---> GND

RX on gsm module ---> TX ftdi
TX in gsm module ---> RX ftdi
GND gsm module ---> GND ftdi

But I dont get the solve solution
Any someone can help me ?


Apr 05, 2019, 03:14 am Last Edit: Apr 05, 2019, 03:22 am by jtbennett
Is your SIM on and blinking once every 3 seconds? Have you tried just flipping the RX/TX wires around and doing a quick AT check? I know it sounds stupid, but I do that sort of thing sometimes.

Secondly, what kind of Arduino model are you using? Uno, Mega?

Thirdly, is your sketch using SoftwareSerial, or are you going direct?

I'll give you a suggestion and if that doesn't work, post your sketch and your specs here and someone smarter will see the issue I'm sure.

I found that with an Uno (or equivalent that uses SoftwareSerial connections), pins 7 and 8 are the ones you wanna use. It's picky for some reason.

I've also found that (at least for my SIM900) it's responsive to AT commands at 19200. Some people say 115200, and that may be true - I may have set mine down a bit, so try each of them out.

Anyway, if you're using an Uno-type board, try the following code:

Code: [Select]

#include <SoftwareSerial.h>
SoftwareSerial Sim900Serial(7,8);

//#define Sim900Serial Serial1
//this is for a mega, ignore it

void setup()
void loop()
   if (Sim900Serial.available())
   if (Serial.available())

Open your serial terminal to the baud rate that you set it at (not the SIM baud) and type your AT and see if there's a response. If not, reupload the sketch using the 115200 baudrate and try again.

Go Up