Go Down

Topic: MKR1300 + Dragino LG01 Gateway + TTN (Read 700 times) previous topic - next topic

c1p81

someone have experience using Dragino Lora Gateway with MKR1300 to connect to TTN (TheThingsNetworks)??

Using this link

https://wiki.dragino.com/index.php?title=Connect_to_TTN#Create_TTN_account

i can create a gateway on TTN console interface and see that is connected.

When i try to upload some data packet to TTN with FirstConfigiration Sketch in examples of MKRWAN library i have this results

1) Using OTAA i have this message on serial console "Something went wrong; are you indoor? Move near a window and retry" ...so the mkr dont connect to the cloud but i can see in Applications/app/Devices/namedevice/Data some Activation Packets arriving on the cloud (no data packet, no payload)

2) Using ABP the mkr seems to connect to the network (no message eror Something.....) but i have "Error sending messages"...no packet on cloud interface

The Dragino support dont have MKR1300 but send me this setup

These settings require user to set the device in ABP mode in LoRaWAN server.

AT+NJM=0 Set to ABP mode
AT+ADR=0 Set the Adaptive Data Rate Off
AT+DR=5  Set Data Rate

someone here suggest to upgrade the firmware and add two functions to set ADR and DR

someone managed to connect and transmit data with this configuration???

Thanks
Luca

MITEL

1) forget OTAA with most single channel gateways, including Dragino LG01 (look here), because they do not manage downlinks.

2) ABP has no real join, so there is no error in using it. The issue is that the basic examples of MKR WAN 1300 send confirmed packets, which again cannot be done with LG01. Change the  parameters of
Code: [Select]
err = modem.endPacket(true) from true to false to send without confirmation.
However, even when sending with confirmation the packet should reach the gateway, but just one every 8 or so, because the gateway is listening to one frequency (and one SF), and the node is sending on at least 3. So,  send more than one time and wait until one packet is received.

Of course the SF should be the one set in the gateway (  modem.dataRate(DR) ), but as far as I remember ADR is off by default. Better to have the firmware updated to the last version.

However, if you want to use packets, you need also to create an app, register the node and put its keys in the secret.h tab of the example. In any case the gateway should see any packet sent on its configured frequency even if not correctly associated to an app.

c1p81

Thanks for the help
Now in ABP i can connect and message is sent correctly (one of 8)
but no data on cloud
i have Spreading factor 7 on Dragino and datarate 5 on MKR1300 (but the option is gray on Dragino)

i have Mkr on last firmware 1.1.6...i will try to check the firmware (and update) on Dragino

Best Regards

L

MITEL

Last fw is 1.1.9, and update the library too.

Just let run the SendReceive example for some minutes to see something reach the cloud. Remember also the duty cycle limit: if you see sending failing on the node, it's because you are sending too often.

c1p81

Thanks i will try...just a very last question
i can see 1.1.9 only as source version but not in binary version
trying to compile in Debian buster i have error Bad substitution on line 166

L

Last fw is 1.1.9, and update the library too.

Just let run the SendReceive example for some minutes to see something reach the cloud. Remember also the duty cycle limit: if you see sending failing on the node, it's because you are sending too often.


MITEL

From the Arduino IDE, among the MKRWAN examples you have also a MKRWANFWUpdateStandalone sketch that does everything (load it on the module).

Go Up