Go Down

Topic: Crypto code not uploading on MKR Wifi 1010 (Read 838 times) previous topic - next topic


i tried many times and followed all instructions properly , even uploaded latest firmware but it still the crypto code doesnt upload at all on the MKR wifi 1010 , i had tried other things on the board and they worked but the crypto code doesnt upload.I am attaching screenshot below anyone please help!

Aabhas Senapati


hi Aabhas

On Thursday we had an issue which was later resolved.
An update to the ArduinoIoTCloud library caused a compilation error in this phase of our Getting Started process.
We noticed pretty soon and resolved it, but some users were affected.
Would you be able to try again?

Thank you for posting here and keep me updated on your tests.



i tried to upload code from arduino create but it doesnt upload and this is the error shown i am attaching below , is that the reason for crypto chip not bieng programmed because i can program the mkr wifi 1010 from arduino ide but not from arduino create.. What should i do to solve this problem.

Aabhas Senapati


There is a know issue currently with uploading in the Arduino Web Editor:
I believe this issue is specific to Windows users. It may also be related to the crypto chip configuration error you encountered.

I would recommend clicking the "Receive Emails" button at the link above to make sure you will get notified if there is any progress with resolving the upload issue. There are a lot of threads about this issue now so it's preferable if we can just update one dedicated thread.


I'm also experiencing the issue but on an Apple Mac. Followed instructions but the message "We weren't able to configure the Crypto Chip." comes up.

Subscribed to emails and alerts.



Hi. Just to be clear, the uploading issue I mentioned in my last reply was fixed a week ago. As long as you are using the Create Agent 1.1.87-fca3237 or newer, that problem will not be the cause of your issue with the crypto code. You can check the Create Agent version by clicking on the Arduino logo in the system tray.


I have this same issue and message today on Windows 7, and my system tray shows Agent 1.1.87-version fca3237.

Sketches compile and run fine with the online and offline IDE).  However, I do receive a "SAM-BA operation failed" error message each time.  Maybe this is related somehow.

"We were unable to upload the Crypto Chip configuration code to your board.

Are you sure the Arduino board is connected properly with a USB cable? Try disconnecting and reconnecting it.  If that doesn't work, try pressing the Reset button twice. You may also write us on the Forum."


FYI, connecting the board through a usb 2.0 hub eliminated the error.  However, connecting directly to the usb 2.0 port on my computer did not work for some reason.

Go Up