Go Down

Topic: cannot upload to MKR1000 (Read 286 times) previous topic - next topic

Jesalpha

Hello, I can't upload anything to my MKR 1000. I have searcher extensivley and even tried to double press the reset button but nothing happens.

I have already connected and uploaded the blink sketch before and it worked then after trying to connect it to the MKR motor carrier it stopped working so I disconnected the motor carrier and tried to reconnect and upload the MKR1000 board on its own again but now it is not working anymore.

Here is the log when I try to upload the blink sketch:

Code: [Select]
Arduino: 1.8.9 (Windows 10), Board: "Arduino/Genuino MKR1000"

Sketch uses 10192 bytes (3%) of program storage space. Maximum is 262144 bytes.
Forcing reset using 1200bps open/close on port COM3
PORTS {COM3, } / {COM3, } => {}
PORTS {COM3, } / {COM3, } => {}
PORTS {COM3, } / {COM3, } => {}
PORTS {COM3, } / {COM3, } => {}
PORTS {COM3, } / {COM3, } => {}
PORTS {COM3, } / {COM3, } => {}
PORTS {COM3, } / {COM3, } => {}
PORTS {COM3, } / {COM3, } => {}
PORTS {COM3, } / {COM3, } => {}
PORTS {COM3, } / {COM3, } => {}
PORTS {COM3, } / {COM3, } => {}
PORTS {COM3, } / {COM3, } => {}
PORTS {COM3, } / {COM3, } => {}
PORTS {COM3, } / {COM3, } => {}
PORTS {COM3, } / {COM3, } => {}
PORTS {COM3, } / {COM3, } => {}
PORTS {COM3, } / {COM3, } => {}
PORTS {COM3, } / {COM3, } => {}
PORTS {COM3, } / {COM3, } => {}
PORTS {COM3, } / {COM3, } => {}
Uploading using selected port: COM3
C:\ProgramData\MATLAB\SupportPackages\R2019a\3P.instrset\arduinoide.instrset\idepkgs\packages\arduino\tools\bossac\1.7.0/bossac.exe -i -d --port=COM3 -U true -i -e -w -v C:\Users\Jessi\AppData\Local\Temp\arduino_build_474133/Blink.ino.bin -R
No device found on COM3
An error occurred while uploading the sketch

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.


Thank you for reading and any help you may provide.

jomoengineer

Check your device manager to see if the COM port has changed.   This should show in the IDE Port selection as well if you are using the Arduino IDE.

What Motor board are you using and how was it connected?

I have an older Make Motor R/C Wicked Devices board and found I had to remove the connection for the SDA and SCL signals from the board to the MKR1000 otherwise it was causing issues.  I did this by using an extra set of Arduino extension headers I had.

Jesalpha

Hi,
Thank You for your reply.
I have uninstalled and reinstalled the board to my PC thus changing the com port. I am trying (and failing) to connect the MKR1000 on its own without the motor board, I  ham using the motor board which comes supplied with the arduino engineering kit.
Is there a way to check if the board is defective/ruined?

pert

Try this:
  • Press and release the reset button on the MKR1000 twice in quick succession. You should now see the onboard LED pulsing, which indicates the MKR1000 is in bootloader mode.
  • Select the port of the MKR1000 from the Tools > Port menu. Make sure not to skip this step, even if you already had the port selected before. The reason is that the port will likely have changed when the board was put in bootloader mode.
  • Sketch > Upload


Hopefully, the upload will now be successful. If so, you should be able to go back to the normal uploading method without needing to activate the bootloader first.

Go Up