Go Down

Topic: mega 2560 mancanza comunicazione (Read 262 times) previous topic - next topic

mistervolt-70

Ragazzi, ad un certo punto l'arduino in oggetto a smesso di comunicare col pc. Ho provato a connettere altri arduino e il pc va bene, ho provato l'arduino su altro pc ma niente. L'unica cosa e che lo schetch che è memorizzato all'interno gira perfettamente, quindi è funzionante... c'è qualche modo per ripristinare la comunicazione o lo devo considerare andato?

docdoc

Definisci "smesso di comunicare".

Ossia spiega passo-passo cosa fai, e cosa succede.
Alex "docdoc" - ** se ti sono stato d'aiuto, un punto karma sarà gradito, clicca su "add" qui a sinistra, vicino al mio nome ;) **

mistervolt-70

nel senso che l'arduino funzina perfettamente. ma se sattacco il pc per apportare modifiche allo schetch non c'è comunicazione, non lo vede. L'ho anche staccato dal circuito, ho anche cambiato pc ma niente.

docdoc

Parliamo di PC Windows o Linux?
Ad esempio se è Windows, se vai in Gestione Periferiche ed attacchi il Mega, non compare proprio la porta COM, oppure compare ma non comunica (in questo caso prova usando un terminale seriale come "putty" impostato ovviamente come serial e sulla COM che vedi comparire)?
Alex "docdoc" - ** se ti sono stato d'aiuto, un punto karma sarà gradito, clicca su "add" qui a sinistra, vicino al mio nome ;) **

mistervolt-70

#4
May 31, 2019, 11:49 pm Last Edit: May 31, 2019, 11:50 pm by mistervolt-70
Parliamo di pc con windows, su gestione periferiche se attacco il mega l'unica porta com presente è la 1, se invece attacco un'altro arduino mi compare la porta (ad es. com 3) e in più sento il segnale acqustico di quando inserisci un usb, co lmega non succede. Sul mega sono accese entrambe le spie (gialla e verde)

zoomx

Se non è il cavo o il connettore il sospettato è il chip USB-seriale presente sulla Mega,  ATMega 16U2.
Puoi sempre riprogrammarlo attraverso il connettore ICSP e forse anche con la seriale con un adattatore USB-seriale che supporti anche il segnale DTR, tipo quello usato con Arduino mini.

gpb01

#6
Jun 01, 2019, 06:48 pm Last Edit: Jun 01, 2019, 06:48 pm by gpb01
Parliamo di pc con windows, su gestione periferiche se attacco il mega l'unica porta com presente è la 1
... se vai "Gestione Computer" -> "Gestione Dispositivi" -> "Porte (COM e LPT)" ti appare la COMx con scritto che si tratta di Arduino Mega o ti appare una COMx che non ha nulla a che vedere con esso ?

Guglielmo
Search is Your friend ... or I am Your enemy !

zoomx

Se ho capito bene quanto scritto nel post #4 quando attacca la Mega non succede nulla mentre se collega altre schede compare la COM corrispondente.
Non si tratta della MCU che sembra funzionare per cui io sospetto la catena USB a partire dalla MCU secondaria 16U2 e il cavo.



Go Up