Go Down

Topic: avrdude: stk500_recv(): programmer is not responding (Read 74867 times) previous topic - next topic

pert

Code: [Select]
Arduino: 1.8.9 (Windows Store 1.8.21.0) (Windows 10), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

Sketch uses 1448 bytes (0%) of program storage space. Maximum is 253952 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 8183 bytes for local variables. Maximum is 8192 bytes.
C:\Users\nigel\Documents\ArduinoData\packages\arduino\tools\avrdude\6.3.0-arduino17/bin/avrdude -CC:\Users\nigel\Documents\ArduinoData\packages\arduino\tools\avrdude\6.3.0-arduino17/etc/avrdude.conf -v -patmega2560 -cwiring -PCOM4 -b115200 -D -Uflash:w:C:\Users\nigel\AppData\Local\Temp\arduino_build_52102/_blink.4sec_delay2.ino.hex:i

avrdude: Version 6.3-20190619
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "C:\Users\nigel\Documents\ArduinoData\packages\arduino\tools\avrdude\6.3.0-arduino17/etc/avrdude.conf"

         Using Port                    : COM4
         Using Programmer              : wiring
         Overriding Baud Rate          : 115200
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: ser_send(): write error: sorry no info avail
avrdude: stk500_send(): failed to send command to serial port
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer

avrdude done.  Thank you.

the selected serial port
 does not exist or your board is not connected

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Make sure you have selected the port of your Arduino board from the Tools > Port menu.

Sometimes the port will be labeled with the board name in the menu. Other times it will not. If you don't know which port is your Arduino, you can find it like this:
  • Unplug your Arduino board from the computer.
  • Tools > Port
  • Note the ports, if any, listed in the menu.
  • Close the Tools menu
  • Plug your Arduino board into the computer.
  • Tools > Port - The new port listed in the menu is your Arduino board.

tmhuud007

I just tried updating today and this is the error message I get when trying upload to NANO.  I have NO problems sending my code to UNO or MICRO:  Can anyone help. This is maddening.  :(

-----------------------------------ERROR CODE BELOW------------------------------------------

Arduino: 1.8.10 (Mac OS X), Board: "Arduino Nano Every, ATMEGA328"

loading hardware from /private/var/folders/93/h8xxfkcn0tqfs_dykh274w4c0000gn/T/AppTranslocation/34475243-6C8C-407C-8561-143B27188356/d/Arduino-3.app/Contents/Java/hardware: following possible symlink /private/var/folders/93/h8xxfkcn0tqfs_dykh274w4c0000gn/T/AppTranslocation/34475243-6C8C-407C-8561-143B27188356/d/Arduino-3.app/Contents/Java/hardware: lstat /private/var/folders/93/h8xxfkcn0tqfs_dykh274w4c0000gn/T/AppTranslocation/34475243-6C8C-407C-8561-143B27188356/d/Arduino-3.app: no such file or directory

Error compiling for board Arduino Nano Every.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

pert

I just tried updating today and this is the error message I get when trying upload to NANO.
Do you have a Nano, or do you have a Nano Every? Despite the similar names, these are very different boards.

tmhuud007

Yes, NANO EVERY is the one I selected.  Thanks for asking. 

Update. Restarted computer several times. Jiggled the USB cable.  Looks like code uploaded. NO errors although.... there is an odd little hardware error (NOT part of the main errors) that came up.  I don't really know if the code was successfully uploaded or not.  I'll have to wire it up and check.  Ugh...

Senna29

HI,

Seem to have same problem just starting up, connecting to Microduino/mCookie-Core (328p)  - for the windmill example

Any suggestions?


Code: [Select]


Arduino: 1.6.7 (Windows 10), Board: "Microduino/mCookie-Core (328p), Atmega328P@16M,5V"

In file included from C:\Program Files (x86)\Arduino For Microduino\examples\00.mCookie_IBC\_01_Windmill\_01_Windmill.ino:49:0:

C:\Program Files (x86)\Arduino For Microduino\hardware\Microduino\avr\libraries\_08_Shield_Microduino_Key/Microduino_Key.h:7:0: warning: "NUM_DIGITAL_PINS" redefined [enabled by default]

 #define NUM_DIGITAL_PINS 22

 ^

In file included from C:\Program Files (x86)\Arduino For Microduino\hardware\Microduino\avr\cores\arduino/Arduino.h:255:0,

                 from sketch\_01_Windmill.ino.cpp:1:

C:\Program Files (x86)\Arduino For Microduino\hardware\Microduino\avr\variants\standard/pins_arduino.h:28:0: note: this is the location of the previous definition

 #define NUM_DIGITAL_PINS            20

 ^

In file included from C:\Program Files (x86)\Arduino For Microduino\hardware\Microduino\avr\libraries\_08_Shield_Microduino_Key\Microduino_Key.cpp:1:0:

C:\Program Files (x86)\Arduino For Microduino\hardware\Microduino\avr\libraries\_08_Shield_Microduino_Key\Microduino_Key.h:7:0: warning: "NUM_DIGITAL_PINS" redefined [enabled by default]

 #define NUM_DIGITAL_PINS 22

 ^

In file included from C:\Program Files (x86)\Arduino For Microduino\hardware\Microduino\avr\cores\arduino/Arduino.h:255:0,

                 from C:\Program Files (x86)\Arduino For Microduino\hardware\Microduino\avr\libraries\_08_Shield_Microduino_Key\Microduino_Key.h:4,

                 from C:\Program Files (x86)\Arduino For Microduino\hardware\Microduino\avr\libraries\_08_Shield_Microduino_Key\Microduino_Key.cpp:1:

C:\Program Files (x86)\Arduino For Microduino\hardware\Microduino\avr\variants\standard/pins_arduino.h:28:0: note: this is the location of the previous definition

 #define NUM_DIGITAL_PINS            20

 ^


Sketch uses 5,594 bytes (17%) of program storage space. Maximum is 32,256 bytes.
Global variables use 398 bytes (19%) of dynamic memory, leaving 1,650 bytes for local variables. Maximum is 2,048 bytes.
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x80
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x80
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x80
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x80
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x80
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x80
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x80
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x80
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x80
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x80
Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

  This report would have more information with
  "Show verbose output during compilation"
  enabled in File > Preferences.

pert

Remove any connections to pins 0 and 1. These pins are used for communication with your computer, including uploads. Connecting anything to these pins can interfere with uploads.

Make sure you have the correct board selected from the custom Tools menu (the part where "Atmega328P@16M,5V" is selected. There are several variations of the Microduino/mCookie-Core (328p) board and you need to make sure you have the configuration set correctly for the board you are using.

Make sure you have selected the port of your Arduino board from the Tools > Port menu.

Sometimes the port will be labeled with the board name in the menu. Other times it will not. If you don't know which port is your Arduino, you can find it like this:
  • Unplug your Arduino board from the computer.
  • Tools > Port
  • Note the ports, if any, listed in the menu.
  • Close the Tools menu
  • Plug your Arduino board into the computer.
  • Tools > Port - The new port listed in the menu is your Arduino board.

abdrahmansoltan

Arduino: 1.8.10 (Windows 10), Board: "Arduino Uno"

Sketch uses 2986 bytes (9%) of program storage space. Maximum is 32256 bytes.
Global variables use 200 bytes (9%) of dynamic memory, leaving 1848 bytes for local variables. Maximum is 2048 bytes.
C:\Users\ZolTA\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17/bin/avrdude -CC:\Users\ZolTA\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17/etc/avrdude.conf -v -patmega328p -carduino -PCOM4 -b115200 -D -Uflash:w:C:\Users\ZolTA\AppData\Local\Temp\arduino_build_547060/sketch_dec08b.ino.hex:i

avrdude: Version 6.3-20190619
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "C:\Users\ZolTA\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17/etc/avrdude.conf"

         Using Port                    : COM4
         Using Programmer              : arduino
         Overriding Baud Rate          : 115200
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x3c
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x3c
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x3c
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x3c
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x3c
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x3c
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x3c
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x3c
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x3c
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x3c

avrdude done.  Thank you.

Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

pert

Remove any connections to pins 0 and 1. These pins are used for communication with your computer, including uploads. Connecting anything to these pins can interfere with uploads.

Make sure you have the correct board selected from the Tools > Board menu.

Make sure you have selected the port of your Arduino board from the Tools > Port menu.

Sometimes the port will be labeled with the board name in the menu. Other times it will not. If you don't know which port is your Arduino, you can find it like this:
  • Unplug your Arduino board from the computer.
  • Tools > Port
  • Note the ports, if any, listed in the menu.
  • Close the Tools menu
  • Plug your Arduino board into the computer.
  • Tools > Port - The new port listed in the menu is your Arduino board.

GrahamPrattWyalong

Hi, I just got back into my office after a fair time away and decided to muck around with my arduinos!

I was notified by the Mac that there was a new version of arduinocc so i downloaded it and lowe and behold i have the same error that everyone here is talking about!

I have many different arduinos lying around and decided to reset several to "Blink".

The non genuine nanos all worked but only after selecting Old boot loader!

The non genuine UNO worked straight away!

The atmega 2560s all worked straight away!

The ARDUINO and SAINSMART leonardos all failed to load! 

so I got the old windows laptop out which was still running version 1.65 and it was quite happy to load the leonardos.

Nothing was happy to run the old genuine UNOs?

All boards were correctly selected, completely bare and as you see were tested against different operating systems and versions.

I then rolled back the boards in board manager on the apple but arduinocc itself was less than happy with that so i am stuck at the moment with having to load different boards from different computers!

Naturally i cannot relistically roll back my apple as the update process is veeeeery long!

I have not tried the old linux laptop as it is under heaps of stuff in the shed somewhere but it was happy to load all of these boards without any problem last time it was booted (four years ago).

Naturally I along with the others who are struggling with the avrdude communication issue would love to see a resolution!

If my old (not updated) windows system and latest updated apple can be of help please let me know what I need to do to give you chaps the information that will help isolate the error... err problem.. heheheh

Cheers.

Graham

pert

Are you using macOS Catalina? If so, I think you are encountering fairly new cause of this error with the Leonardos:
https://github.com/arduino/Arduino/issues/9290

pantherenjoys

Arduino: 1.8.10 (Windows 7), Board: "Arduino Nano, ATmega328P"

Sketch uses 968 bytes (3%) of program storage space. Maximum is 30720 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.
D:\arduino\hardware\tools\avr/bin/avrdude -CD:\arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM5 -b115200 -D -Uflash:w:C:\Users\AnEl\AppData\Local\Temp\arduino_build_879549/Blink.ino.hex:i

avrdude: Version 6.3-20190619
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "D:\arduino\hardware\tools\avr/etc/avrdude.conf"

         Using Port                    : COM5
         Using Programmer              : arduino
         Overriding Baud Rate          : 115200
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x17
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x17
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x17
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x17
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x17
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x17
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x17
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x17
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x17
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x17

Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.
avrdude done.  Thank you.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

pert

Arduino: 1.8.10 (Windows 7), Board: "Arduino Nano, ATmega328P"
Select Tools > Processor > ATmega328P (Old Bootloader) and try uploading again.

noob314

#42
Dec 14, 2019, 12:25 pm Last Edit: Dec 14, 2019, 12:39 pm by noob314
To moderator:

Why not simply make one sticky topic regarding upload issue and the most probable causes? There is at least 10 new topics with the same question in last 10 days and the same replies with steps for solving ...

diymonk

I had the same issue.

This is probably the case with boards sourced from local shops.

I could resolve it by choosing the following menu option in the Arduino IDE:

         Tools > Processor > ATmega328P (Old Bootloader)



BRs
DM

tsfarber

I was getting the same error string on a Nano clone from a kit. Thank you to everyone who suggested to run the program with the ATmega328P (Old BootLoader) selected as processor. That fixed my problem. I also found helpful the advice to test my Nano unit with the basic blink sketch. I got the same error running blink, changed the bootLoader and blink worked fine. Then I ran the program I started with and that uploaded fine as well.

Go Up