Go Down

Topic: avrdude: stk500_recv(): programmer is not responding (Read 26178 times) previous topic - next topic

bbev

Power down the board. Disconnect any wires to the ground and reset pins of your board. Connect the usb cable, & try to upload again. Power down the board, reconnect any wires, and then power it back up. See if it works.

DarthBobo

I had a similar issue today, turns out it was my USB cable!

I was using a charge only cable, not a data cable. Definitely worth a check.

Eris1173

#47
Jan 22, 2020, 10:11 pm Last Edit: Jan 24, 2020, 06:27 pm by Eris1173
Worked like a charm few months ago..
I installed a new SSD on my laptop so installed the latest Arduino IDE since than the upload not works.
 
OS: Ubuntu 19.10
I using an official starter Arduino Uno kit with all of its own cable and parts.

power off/on, cable unplug, board reset not helped...
no cabling on the pins.

#---------
# dmesg:
#---------

[19433.210539] cdc_acm 3-4:1.0: ttyACM0: USB ACM device
[19720.400759] usb 3-4: USB disconnect, device number 6
[19725.856779] usb 3-4: new full-speed USB device number 7 using xhci_hcd
[19726.006591] usb 3-4: New USB device found, idVendor=2a03, idProduct=0043, bcdDevice= 0.01
[19726.006594] usb 3-4: New USB device strings: Mfr=1, Product=2, SerialNumber=220
[19726.006596] usb 3-4: Product: Arduino Uno
[19726.006597] usb 3-4: Manufacturer: Arduino Srl           
[19726.006598] usb 3-4: SerialNumber: 75435363138351D07180
[19726.007305] cdc_acm 3-4:1.0: ttyACM0: USB ACM device


#--------------------
#Upload debug log:
#--------------------

Arduino: 1.8.10 (Linux), Board: "Arduino Uno"

Sketch uses 924 bytes (2%) of program storage space. Maximum is 32256 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.
/home/$USER/.arduino15/packages/arduino/tools/avrdude/6.3.0-arduino17/bin/avrdude -C/home/$USER/.arduino15/packages/arduino/tools/avrdude/6.3.0-arduino17/etc/avrdude.conf -v -patmega328p -carduino -P/dev/ttyACM0 -b115200 -D -Uflash:w:/tmp/arduino_build_51263/Blink.ino.hex:i

avrdude: Version 6.3-20190619
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "/home/$USER/.arduino15/packages/arduino/tools/avrdude/6.3.0-arduino17/etc/avrdude.conf"
         User configuration file is "/home/$USER/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/ttyACM0
         Using Programmer              : arduino
         Overriding Baud Rate          : 115200
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00

avrdude done.  Thank you.

Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.


Any Idea?
Thanks!

pert

Code: [Select]
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
Try a loopback test:
  • Disconnect power from the board.
  • Remove all connections and shields from the board.
  • Force the processor to remain in reset by connecting a jumper wire from the RESET to the GND pin.
  • Connect a jumper from the RX pin (Arduino pin 0) to the TX pin (Arduino pin 1).
  • Connect the board to your computer.
  • Select the port of your board from the **Tools > Port** menu.
  • **Tools > Serial Monitor**
  • Type some text into the input field at the top of the Serial Monitor window.
  • Press Enter. If the text you typed is shown in Serial Monitor's output window, the loopback test passed. If the text was not shown, the loopback test failed.
  • Close Serial Monitor.
  • Disconnect the board from the computer.
  • Remove the two jumper wires.


If the loopback test failed, the USB to TTL serial adapter is damaged and it's unlikely to be worth repairing your board.

If the loopback test passed, or if you skipped the loopback test. Try doing a Burn Bootloader. You'll need an ISP programmer. If you don't own a programmer, you can use a spare Arduino board as an "Arduino as ISP" programmer:
https://www.arduino.cc/en/Tutorial/ArduinoISP

v_mark

Hi all,
I have a very special case, but I found the same error.

Special case:
  • My Arduino UNO attached to an USB capable router running with LEDE/OpenWRT.
  • This Arduino UNO drives an RGB LED strip, count power consumption (electric, gas - soon), will do other things as well.
  • It is "burried" in the "computer cabinet", so it is inconvenient to reach directly, and needs the connected "hardware" to able to check/debug.
  • I collect energy data and drive LEDs at "high lvl" from the router (automated), so USB is used for communication as well, so
  • I had to programmatically allow/inhibit immediate Arduino reset after each device open - see details in this forum post
  • My Arduino IDE 1.8.10 runs on my Laptop (os:Ubuntu 19.04).
  • When I want to upload new sketch, I "export" Arduino UNO USB port through TCP/IP via USBIP
  • I attach my Laptop to Arduino USB (again, via USBIP)


Everything works fine, like:
  • USB monitor window (laptop sees Arduino as /dev/ttyUSB0)
  • Upload sketch (confirmed, sketch burning goes well)


BUT

Just after sketch write Arduino get a power cycle (normal behaviour) and ...
I assume IDE would like to catch the bootloader (without success) and read back the code?

At this point I get the subjected error.
However a moment later (when Arduino boots? when USBIO connection reestablished?) everything (including USB monitor window) works fine.

Because this is very likely not avrdude related AND I can use Arduino IDE same as I would program "local" Arduino, I have no time to track down the problem.

If only somebody (who knows Arduino IDE well) could confirm that I lost "only" a kind of safety net, so I will recognise harder if my code somehow will not uploaded...

Thank you very much.

Code: [Select]
Arduino: 1.8.10 (Linux), Alaplap:"Arduino Uno"

In file included from /home/mark/Arduino/RGB-LED-USB-comm/RGB-LED-USB-comm.ino:1:0:
/home/mark/Arduino/libraries/FastLED/FastLED.h:14:21: note: #pragma message: FastLED version 3.003.002
 #    pragma message "FastLED version 3.003.002"
                     ^~~~~~~~~~~~~~~~~~~~~~~~~~~
A vázlat 7192 bájt (22%)-ot használ a program tárhelyből. A maximum 32256 bájt.
A globális változók 672 bájt (32%)-ot használnak a dinamikus memóriából, 1376 bájtot hagyva a helyi változóknak. A maximum 2048 bájt.
/home/mark/.arduino15/packages/arduino/tools/avrdude/6.3.0-arduino17/bin/avrdude -C/home/mark/.arduino15/packages/arduino/tools/avrdude/6.3.0-arduino17/etc/avrdude.conf -v -patmega328p -carduino -P/dev/ttyUSB0 -b115200 -D -Uflash:w:/tmp/arduino_build_863112/RGB-LED-USB-comm.ino.hex:i

avrdude: Version 6.3-20190619
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "/home/mark/.arduino15/packages/arduino/tools/avrdude/6.3.0-arduino17/etc/avrdude.conf"
         User configuration file is "/home/mark/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/ttyUSB0
         Using Programmer              : arduino
         Overriding Baud Rate          : 115200
         AVR Part                      : ATmega328P
         Chip Erase delay              : 9000 us
         PAGEL                         : PD7
         BS2                           : PC2
         RESET disposition             : dedicated
         RETRY pulse                   : SCK
         serial program mode           : yes
         parallel program mode         : yes
         Timeout                       : 200
         StabDelay                     : 100
         CmdexeDelay                   : 25
         SyncLoops                     : 32
         ByteDelay                     : 0
         PollIndex                     : 3
         PollValue                     : 0x53
         Memory Detail                 :

                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           eeprom        65    20     4    0 no       1024    4      0  3600  3600 0xff 0xff
           flash         65     6   128    0 yes     32768  128    256  4500  4500 0xff 0xff
           lfuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           hfuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           efuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           lock           0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           calibration    0     0     0    0 no          1    0      0     0     0 0x00 0x00
           signature      0     0     0    0 no          3    0      0     0     0 0x00 0x00

         Programmer Type : Arduino
         Description     : Arduino
         Hardware Version: 3
         Firmware Version: 4.4
         Vtarget         : 0.3 V
         Varef           : 0.3 V
         Oscillator      : 28.800 kHz
         SCK period      : 3.3 us

avrdude: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.01s

avrdude: Device signature = 0x1e950f (probably m328p)
avrdude: reading input file "/tmp/arduino_build_863112/RGB-LED-USB-comm.ino.hex"
avrdude: writing flash (7192 bytes):

Writing | ################################################## | 100% 1.83s

avrdude: 7192 bytes of flash written
avrdude: verifying flash memory against /tmp/arduino_build_863112/RGB-LED-USB-comm.ino.hex:
avrdude: load data flash data from input file /tmp/arduino_build_863112/RGB-LED-USB-comm.ino.hex:
avrdude: input file /tmp/arduino_build_863112/RGB-LED-USB-comm.ino.hex contains 7192 bytes
avrdude: reading on-chip flash data:

Reading | ###avrdude: stk500_recv(): programmer is not responding
#avrdude: stk500_recv(): programmer is not responding
avr_read(): error reading address 0x0000
    read operation not supported for memory "flash"
avrdude: failed to read all of flash memory, rc=-2
avrdude: stk500_recv(): programmer is not responding

avrdude done.  Thank you.

a kiválasztott soros port
 nem létezik vagy az alaplap nincs csatlakoztatva

Ennek a jelentésnek több információja lehetne
a "Bővebb kimenet mutatása fordításkor"
opció engedélyezésével a Fájl -> Beállítások-ban.

pert

If only somebody (who knows Arduino IDE well) could confirm that I lost "only" a kind of safety net, so I will recognise harder if my code somehow will not uploaded...
It's the verification step that's failing. That's where it reads the uploaded binary back from the microcontroller's flash memory and compares it to the .hex file on your hard drive. Verification is intended to alert you if the data was somehow corrupted during the upload. After reading tens of thousands of posts on the forum over the last 7 years, I don't remember a case of the verification catching a legitimate problem, so I don't think it's a big deal if it's not working for you. You can turn it off in the Arduino IDE at File > Preferences > Verify code after upload.

RicardoPenders1982

After installing some updates I also got the issue that I couldn't upload any sketch anymore, the only thing I had to change is to select the old bootloader to fix the problem.
Now everything works as it did before so I highly recommend for those with the same issue to first try to select the old bootloader and then try again before you start doing anything else.
For those with the Chinese clone with the CH340 USB SERIAL chip on board make sure you have selected the right programmer, it should be AVRISP mkII
Check your COM port too and if you selected the right Arduino board.
If these changes still don't work I suggest to completely remove your IDE software and reinstall everything, don't forget to reinstall the USB driver too if you have the Chinese clone, then it should be working again.
I hope this is helpful to you and I wish you success figuring it out.

Lazerblade604

Code: [Select]
Arduino: 1.8.9 (Windows Store 1.8.21.0) (Windows 10), Board: "Arduino/Genuino Uno"

Sketch uses 5578 bytes (17%) of program storage space. Maximum is 32256 bytes.
Global variables use 248 bytes (12%) of dynamic memory, leaving 1800 bytes for local variables. Maximum is 2048 bytes.
C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.21.0_x86__mdqgnx93n4wtt\hardware\tools\avr/bin/avrdude -CC:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.21.0_x86__mdqgnx93n4wtt\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM3 -b115200 -D -Uflash:w:C:\Users\nicoj.000\AppData\Local\Temp\arduino_build_89552/Turret_code_arduinouno_.ino.hex:i

avrdude: Version 6.3-20171130
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.21.0_x86__mdqgnx93n4wtt\hardware\tools\avr/etc/avrdude.conf"

         Using Port                    : COM3
         Using Programmer              : arduino
         Overriding Baud Rate          : 115200
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x3f
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x3f
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x3f
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x3f
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x3f
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x3f
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x3f
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x3f
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x3f
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x3f

avrdude done.  Thank you.

Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

pert

I highly recommend for those with the same issue to first try to select the old bootloader and then try again before you start doing anything else.
Good advice for anyone with a Nano having this problem.

make sure you have selected the right programmer, it should be AVRISP mkII
The Tools > Programmer menu selection is only used when you are doing Tools > Burn Bootloader or Sketch > Upload Using Programmer. When you are doing a standard upload, the Tools > Programmer menu selection is completely ignored, so it doesn't matter what you have it set to.

Check your COM port too and if you selected the right Arduino board.
More good advice!

If these changes still don't work I suggest to completely remove your IDE software and reinstall everything
I can't think of a case where re-installing the IDE would solve this particular error. There are other upload errors that can be fixed by reinstalling the hardware package (e.g., Arduino AVR Boards), but that is when it's installed to the Arduino15 (or .arduino15 on Linux) folder, and uninstalling the Arduino IDE doesn't touch that folder, so the problem remains after the IDE re-installation.

pert

Code: [Select]
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x3f
Remove any connections to pins 0 and 1. These pins are used for communication with your computer, including uploads. Connecting anything to these pins can interfere with uploads.

Make sure you have the correct board selected from the Tools > Board menu.

Make sure you have selected the port of your Arduino board from the Tools > Port menu.

Sometimes the port will be labeled with the board name in the menu. Other times it will not. If you don't know which port is your Arduino, you can find it like this:
  • Unplug your Arduino board from the computer.
  • Tools > Port
  • Note the ports, if any, listed in the menu.
  • Close the Tools menu.
  • Plug your Arduino board into the computer.
  • Tools > Port - The new port listed in the menu is your Arduino board.

manjureddy

</>
Code: [Select]
Arduino: 1.8.10 (Windows 7), Board: "Arduino/Genuino Uno"

Sketch uses 3468 bytes (10%) of program storage space. Maximum is 32256 bytes.
Global variables use 306 bytes (14%) of dynamic memory, leaving 1742 bytes for local variables. Maximum is 2048 bytes.
C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM5 -b115200 -D -Uflash:w:C:\Users\ADMINI~1\AppData\Local\Temp\arduino_build_399939/tachometer.ino.hex:i

avrdude: Version 6.3-20190619
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

         Using Port                    : COM5
         Using Programmer              : arduino
         Overriding Baud Rate          : 115200
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xb4
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0xb4
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0xb4
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0xb4
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0xb4
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0xb4
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0xb4
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0xb4
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0xb4
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0xb4

avrdude done.  Thank you.

Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

pert

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xb4
avrdude: stk500_recv(): programmer is not responding
Remove any connections to pins 0 and 1. These pins are used for communication with your computer, including uploads. Connecting anything to these pins can interfere with uploads.

Make sure you have the correct board selected from the Tools > Board menu.

Make sure you have selected the port of your Arduino board from the Tools > Port menu.

Sometimes the port will be labeled with the board name in the menu. Other times it will not. If you don't know which port is your Arduino, you can find it like this:
  • Unplug your Arduino board from the computer.
  • Tools > Port
  • Note the ports, if any, listed in the menu.
  • Close the Tools menu.
  • Plug your Arduino board into the computer.
  • Tools > Port - The new port listed in the menu is your Arduino board.

glebscape

stk500_recv(): programmer is not responding).
In my case with two brandnew Nano v3/CH340.
1. Check is board connected and responsing - Tools->Get Board Info
2. Change PROCESSOR type for ATmega328P (Old Bootloader)
3. Try upload sketch from Examples (like Blink) File->Examples->01.Basics->Blink (Crl+U)
Thats all!

pert

Thanks glebscape, but I already gave harshith08 that same advice 10 months ago. I certainly hope they are not still having problems with their board.

Kukka

Are you saying you have multiple Arduino boards that all started having the same problem at the same time?
It's impossible to say whose problem this is. Many thousands of people are using Arduino's software every day with absolutely no problems uploading. Of the tiny percentage who do have uploading errors, the vast majority are caused by user error or damaged/defective hardware. Anyway, it's not really productive to talk about whoese problem it is.


If you have any external circuitry connected to your Arduino board, try disconnecting it to see if that solves the problem.
Second option solved the issue. Take out all the external circuits which are connected to your board

Go Up