Go Down

Topic: avrdude: stk500_recv(): programmer is not responding (Read 95168 times) previous topic - next topic

pert

Under Tools the selected board is "Arduino Uno"
This is the cause of the error. Despite the similar names, the Uno WiFi Rev2 is very different from the classic Uno. You need to install the boards platform for the Uno WiFi Rev2 and then use the correct board selection:
  • Tools > Board > Boards Manager
  • Wait for the downloads to finish.
  • From the list of boards platforms, select "Arduino megaAVR Boards".
  • If it's not already installed, click the "Install" button.
  • Wait for the installation to finish.
  • Click the "Close" button.
  • Tools > Board > Arduino megaAVR Boards > Arduino Uno WiFi Rev2

Now try uploading again.

corm

Thanks that was the problem :-( it worked on Win10 and failed on Ubuntu due to into some permission issues I need to figure out.

Cheers...

pert

For Linux, try the last part of the Linux-specific instructions from the Uno WiFi Rev2's "Getting Started" page:
https://www.arduino.cc/en/Guide/ArduinoUnoWiFiRev2#installing-drivers-for-the-uno-wifi
Quote
Linux There is no need to install drivers for Ubuntu 10.0.4 and later, but make sure port 5353 is not being blocked by a firewall. Users with Linux need to run this code in the terminal:
Code: [Select]
~/.arduino15/packages/arduino/hardware/megaavr/1.8.1/scripts/create_dfu_udev_rule
but note that path is outdated. The instructions I provided above will have installed the latest version of Arduino megaAVR Boards: 1.8.3, but the instructions were written for Arduino megaAVR Boards 1.8.1, so you just need to update the version folder name in that path:
Code: [Select]
~/.arduino15/packages/arduino/hardware/megaavr/1.8.3/scripts/create_dfu_udev_rule

kelogs

For me it was a matter of `-B 10` instead of `-b xxxx`. So:

Code: [Select]
sudo ~/arduino-1.8.12/hardware/tools/avr/bin/avrdude -P /dev/ttyACM0 -B 10 -c arduino -p m328p -C ~/.arduino15/packages/arduino/tools/avrdude/6.3.0-arduino17/etc/avrdude.conf -U eeprom:r:eeprom.hex:r

pert

They are two different options:
https://www.nongnu.org/avrdude/user-manual/avrdude_4.html#:~:text=-b%20baudrate
Quote
-b baudrate
Override the RS-232 connection baud rate specified in the respective programmer's entry of the configuration file.
https://www.nongnu.org/avrdude/user-manual/avrdude_4.html#:~:text=-B%20bitclock
Quote
-B bitclock
Specify the bit clock period for the JTAG interface or the ISP clock (JTAG ICE only). The value is a floating-point number in microseconds. The default value of the JTAG ICE results in about 1 microsecond bit clock period, suitable for target MCUs running at 4 MHz clock and above. Unlike certain parameters in the STK500, the JTAG ICE resets all its parameters to default values when the programming software signs off from the ICE, so for MCUs running at lower clock speeds, this parameter must be specified on the command-line. It can also be set in the configuration file by using the 'default_bitclock' keyword.

omayadewashmi

Hello, I Have a arduino nano board and i can't upload any program. Allways show this error. Help me !

avrdude: usb_fill_buff(): usb_bulk_read() error =-7
avrdude: stk500_recv(): programmer is not responding

pert

Please do this:
  • (In the Arduino IDE) File > Preferences
  • Uncheck the checkbox next to "Show verbose output during: compilation"
  • Check the checkbox next to "Show verbose output during: upload
  • Click "OK"
  • Sketch > Upload
  • After the upload fails, you'll see a button on the right side of the orange bar "Copy error messages" (or the icon that looks like two pieces of paper at the top right corner of the black console window in the Arduino Web Editor). Click that button.
  • In a forum reply here, click on the reply field.
  • Click the </> button on the forum toolbar. This will add the forum's code tags markup to your reply.
  • Press "Ctrl + V". This will paste the upload output between the code tags.
  • Move the cursor outside of the code tags before you add any additional text to your reply.

stefan64

Arduino: 1.8.13 (Windows 10), Board: "ATtiny13, 4.8 MHz internal osc., EEPROM retained, BOD 4.3V, Micros enabled"

C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware\MicroCore-master\avr/avrdude.conf -v -pattiny13 -cstk500v1 -B32 -PCOM6 -b19200 -e -Ulock:w:0x3f:m -Uhfuse:w:0xf9:m -Ulfuse:w:0b00111001:m



avrdude: Version 6.3-20190619

         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

         Copyright (c) 2007-2014 Joerg Wunsch



         System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\MicroCore-master\avr/avrdude.conf"



         Using Port                    : COM6

         Using Programmer              : stk500v1

         Overriding Baud Rate          : 19200

         Setting bit clk period        : 32.0

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x03

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x03

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x03

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x03

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x03

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x03

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x03

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x03

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x03

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x03



avrdude done.  Thank you.



Fehler beim Brennen des Bootloaders.


pert

Code: [Select]
Arduino: 1.8.13 (Windows 10), Board: "ATtiny13, 4.8 MHz internal osc., EEPROM retained, BOD 4.3V, Micros enabled"

...

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x03
Did you upload the File > Examples > 11.ArduinoISP > Arduino ISP sketch to the Arduino board you're using as an "Arduino as ISP" programmer?.

stefan64


pert

You're welcome. I'm glad if I was able to be of assistance. Enjoy!
Per

bobbybell49

similar error message while trying to upload code using a ch30 based programmer and standard Arduino UNO... below is the verbose upload messages.  I've been told to make the baud rate for upload 9600 - but can't find 'the' config file that causes that change.

Arduino: 1.8.13 (Windows Store 1.8.42.0) (Windows 10), Board: "Arduino Uno"

Sketch uses 1992 bytes (6%) of program storage space. Maximum is 32256 bytes.

Global variables use 194 bytes (9%) of dynamic memory, leaving 1854 bytes for local variables. Maximum is 2048 bytes.

C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.42.0_x86__mdqgnx93n4wtt\hardware\tools\avr/bin/avrdude -CC:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.42.0_x86__mdqgnx93n4wtt\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM3 -b115200 -D -Uflash:w:C:\Users\bobbe\AppData\Local\Temp\arduino_build_979322/sketch_sep23a.ino.hex:i



avrdude: Version 6.3-20190619

         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

         Copyright (c) 2007-2014 Joerg Wunsch



         System wide configuration file is "C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.42.0_x86__mdqgnx93n4wtt\hardware\tools\avr/etc/avrdude.conf"



         Using Port                    : COM3

         Using Programmer              : arduino

         Overriding Baud Rate          : 115200

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xa4

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0xa4

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0xa4

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0xa4

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0xa4

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0xa4

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0xa4

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0xa4

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0xa4

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0xa4



avrdude done.  Thank you.



Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.



This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

pert

I've been told to make the baud rate for upload 9600
Unless you have a modified bootloader, this is wrong. Most likely they were thinking of the baud rate of the Serial Monitor, which has nothing to do with uploading. So forget about that advice for now (and probably forever).

Remove any connections to pins 0 and 1 on your Arduino board. These pins are used for communication with your computer, including uploads. Connecting anything to these pins can interfere with uploads.

Make sure you have the correct board selected from the Tools > Board menu.

Make sure you have selected the port of your Arduino board from the Tools > Port menu.

Sometimes the port will be labeled with the board name in the menu. Other times it will not. If you don't know which port is your Arduino board, you can find it like this:
  • Unplug your Arduino board from the computer.
  • Tools > Port
  • Note the ports, if any, listed in the menu.
  • Close the Tools menu. The ports list is only updated when the Tools menu is re-opened, so this step is essential.
  • Plug your Arduino board into the computer.
  • Tools > Port - The new port listed in the menu is your Arduino board.

bobbybell49

thanks for the quick reply. 

I'm trying to use a ch340 based programmer. (DSD TECH USB to TTL Serial Adapter with FTDI FT232RL Chip) 

This device connects to the USB on my computer and then the following connections on the UNO:

DTR --> Reset
GND --> GND
VCC --> VIN
TX --> RX
RX --> TX

The serial monitor works - I downloaded code (using the std usb programming cable for the UNO) and that code writes to the serial port every half second.

I'm just not able to upload new code via this connection...

CrossRoads

"ch340 based programmer. (DSD TECH USB to TTL Serial Adapter with FTDI FT232RL Chip) "

What? ch340 and FT232 are both USB/TTL Serial adapters.

You have a board that has both on it? Post a link to it.  Something sounds off.
Designing & building electrical circuits for over 25 years.  Screw Shield for Mega/Due/Uno,  Bobuino with ATMega1284P, & other '328P & '1284P creations & offerings at  my website.

Go Up