Go Down

Topic: Cannot create Access Point (AP). (Read 292 times) previous topic - next topic

Ayman1993

Apr 11, 2019, 01:24 am Last Edit: Apr 11, 2019, 04:29 am by Ayman1993
I've just recently purchased the MKRWIFI1010 for my senior design project in which I want to use the micro controller's PWM in order to power a motor controller. the first thing i did was make sure that all the firmware was up to date.

I ran the AP_SimpleWebServer example and it was a success. I was able to access it through my laptop and manipulate the LED.

I moved on to look at some of the other examples which all worked out fine as well, however returning to the AP_SimpleWebServer example I now keep getting the message in the serial connection stating that "Creating access point failed" and I am no longer able to create one.

I've done hours of online research but couldn't find anything can anyone help?

automatisasie

#1
Oct 12, 2019, 02:39 pm Last Edit: Oct 12, 2019, 02:41 pm by automatisasie
Hi Ayman,

I am getting the same "Creating access point failed"-message with my Uno+WiFi Rev.2. I tried downgrading the firmware from 1.2.4 to 1.2.1 which was reported as the latest version by the CheckFirmwareVersion-tool after I installed 1.2.4. Weird. And no luck.

Did you solve this problem?

Regards,

Huib.

automatisasie

Hi,

I found the solution in another thread: https://forum.arduino.cc/index.php?topic=607797.0

It says there: "In 'AP_SimpleWebServer' Change: 'status = WiFi.beginAP(ssid, pass);'  to   'status = WiFi.beginAP(ssid);'"

Why there is still wrong code in the demo-program and why we don't get a proper error message, I don't know yet. But for everyone with the same problem googling to this page: dump the password and it works.

Regards,

Huib.

Go Up