Go Down

Topic: Seting up my own custom board for IDE (Read 131 times) previous topic - next topic

Alkerion

Hi!

I want to modify the Bootloader of my Mega 2560, for this, I want to create my own branch of board under hardware.


I've started to create a "my_boards" directory in "C:\Users\...\Arduino\hardware", and an "avr" directory in "my_boards"

Then, I've make a copy of board.txt that I've placed in my own "avr" directory.

I've created a "bootloader" directory and copied "stk500v2" folder from "arduino/avr/booloader".

I've modified the files accordingly to my needs (set the new cpu speed).

The problem now is that Arduino IDE and VS2019 doesn't see my board.

What dis I miss ?

Regards

pert

The problem now is that Arduino IDE and VS2019 doesn't see my board.

What dis I miss ?
Please put your whole my_boards folder in a .zip file and attach it to a reply here. If you click the "Reply" button here, you will see an "Attachments and other settings" link, through which you can do the attachment.

I'll have a look and see if I can't spot the problem.

Alkerion

HI !

Here is my folder.

Thanks for your support.

Regards

pert

What do you mean by "doesn't see my board"? I installed your hardware package and it now shows up in the Arduino IDE at Tools > Board > Arduino Mega or Mega 2560 22Mhz. I don't know anything about VS2019, but I'd expect it to work similarly to the Arduino IDE.

You need to restart the Arduino IDE after installing the package before it will be recognized.

Make sure that File > Preferences > Sketchbook location is set to your "C:\Users\...\Arduino" folder (or move the package to wherever your sketchbook location is).

There is a compilation error, but that's probably the next thing to worry about.

Alkerion

#4
Apr 16, 2019, 11:30 am Last Edit: Apr 16, 2019, 11:31 am by Alkerion
OK !

That's good, now I see it !

Thanks



Go Up