Go Down

Topic: IDE 1.6.5 is now available for download (Read 90357 times) previous topic - next topic

Jantje

actually your cpu is loaded 100% all the time. Your CPU does not know the difference between being idle or working. (just like your arduino). The OS can recognize certain situations and this is shown in the CPU monitor. What the load monitor shows is what the OS (in casu windows) thinks is "non productive wait time".

I have seen many programs causing the CPU monitor to think there is no "non productive wait time left" (=100% load) that did not create an abnormal cpu load and left more than enough "non productive wait time" for other programs and the OS to respond nicely.

There is only a problem if the computer actually would be non responsive. If your computer is responsive and your meter (in casu the cpu resource meter) says it has 100% load; the meter is not working properly.

What I'm trying to say is: "It is not easy to make a good CPU load meter. Trust your instinct more than the meter."
Jantje
Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

anandr

Hi there.
Yesterday I downloaded Arduino IDE 1.6.5.
Sometimes, when I compile my sketch with "arduino.exe" it shows error messages (see the attached file) and does not compile the sketch. Sometimes it compiles the same sketch without any errors.
The sketch is rather big:
Quote
Sketch uses 31,622 bytes (98%) of program storage space. Maximum is 32,256 bytes.
    Global variables use 1,536 bytes (75%) of dynamic memory, leaving 512 bytes for local variables. Maximum is 2,048 bytes.
When I run "arduino_debug.exe", the same sketch is compiled without any errors.

Other sketches are compiled without any errors so far.

In principle, when there is no error, the sketch is uploaded to Arduino Uno and correctly works there.
But such behavior is annoying.

By the way, Arduino 1.5.8 works OK without any error messages.

Is it Arduino IED bug or just a consequence of my Arduino setup?

My configuration is:
 - Win7 64bit
 - Stand-alone Arduino setup (zip) in a folder where write permissions are not checked
        C:\ProgramFiles\Arduino\arduino-1.6.5-r5
 - "portable" folder was created in Arduino folder as a symlink to actual Arduino "portable" folder
    This allows me to switch to different IDE version without moving sketches
        and creating different project versions in different IDEs
 - External editor (Sublime Text) is used instead of Arduino built-in editor.
    Arduino is used only to compile/upload sketch

granteverson

I paid for this site and want to downlload files but it wants me to pay again how do I download with out paying again, and again, and again?

gonnie08


Leif_55

#199
Oct 31, 2015, 09:39 pm Last Edit: Oct 31, 2015, 09:41 pm by Leif_55
Hi,
I am running an iMac and have been using 1.6.0 for some time.
Today I downloaded 1.6.5
After uploading sketches related to the adafruit GPS board i suddenly found out that I no longer could access the SD card reader on my computer.
I tried inserting the card in my MBP laptop and that worked fine.
I then restarted my iMac and it was fine again.
However, after uploading the GPS logging sketch I again had the problem with being unable to connect to the SD card.
Rebooting and reverting to 1.6.0 everything worked fine again.
There seems to be a leak somewhere in 1.6.5 that affects the operating system of my iMac.
There are some nice functions like the better way the serial monitoring window stays alive, but the effects on the system are a great concern and needs to be fixed.

amvoltas13

Hi

I am facing the the problem of compiling of 1sheeld codes without connecting the hardware to the pc .
Its showing fatal error ,compiling terminated.....
Why that so ?What should be the probable cause ?
Although the arduino basic codes are compiling properly with no such error..

please post your valuable suggestions ..

Thanks & regards.

timmoore46

#201
Nov 06, 2015, 10:29 am Last Edit: Nov 06, 2015, 10:31 am by timmoore46
Don't open it with software center, just right click, unpack, open folder, double click "arduino"
The question is how do I get the download installed ?  its    arduino-1.6.6-linux64.tar.xz

installed ?

I've unpacked it and found 'arduino', but when I double click it I get a load of bash commands.

I'm a newbie to this sort of install.

What should I do next?  (I'm using ubuntu 64 bit 14.04)

Any thoughts very very welcome,

:  )))

Tim

68tjs

Unless you want to use a Zero or a DUE you do not need a superior version to 1.0.5 (or 1.0.6) located in the Ubuntu repositories.
 For AVR 8 bit micro, versions 1.5.x or 1.6.x (or 1.7.x)  bring mainly cosmetic effects but very little improvement.


nielyay


Raut123

i was unable to find the hex file after compiling, .ino file is also not there .

Go Up