Go Down

Topic: Need to run IDE using sudo ? (Read 228 times) previous topic - next topic

jski3

Apr 19, 2019, 10:27 pm Last Edit: Apr 19, 2019, 10:40 pm by jski3
Just installed Raspbian on yet another Raspberry Pi 3. Tried running the Arduino IDE, no problems ... until I tried to "Upload Using Programmer". I got this:

Quote
avrdude: Warning: cannot open USB device: Permission denied
avrdude: Error: Could not find USBtiny device (0x1781/0xc9f)
If I run the IDE using root privileges (i.e.,sudo), of course it works.

This is not the same behavior I see on my Fedora 29 machine. No need for sudo there.

Any ideas?

Oh yeah, I'm using 1.8.9 with the latest Raspbian updates.

pert


jski3

Thanks for the reply.

But this really doesn't apply here.

Since I'm using the Pocket AVR Programmer (SparkFun) and there's no device file (/dev/) to check which group has privileges to it.

As a matter of fact I asked about this earlier: Where's the device file for the Pocket AVR Programmer?

Never got a response.

pert

OK, sorry I didn't read carefully enough. From the product page, it sounds like the Pocket AVR Programmer is actually a USBtinyISP that Sparkfun decided to give a different name to make things more confusing. Therefore, I think this information will apply:
https://learn.adafruit.com/usbtinyisp/avrdude#for-linux-12-7. I checked the driver to be sure and the VID and PID are indeed the same as the USBtinyISP.

jski3

#4
Apr 20, 2019, 05:10 pm Last Edit: Apr 20, 2019, 05:13 pm by jski3
That did it! Thanks!

Just added an additional udev rules file with the prescribed elixir inside and rebooted.

No need for sudo now.   

pert

You're welcome. I'm glad to hear it's working now. Enjoy!
Per

Go Up