Go Down

Topic: Problema con relè  (Read 2268 times) previous topic - next topic

Maurotec

Quote
Fosse fornito il negozio sotto casa (che sono i 10km perchè sotto casa ho solo sassi e polvere)
Sassi e polvere :D , ah  come ti capisco.

Ciao.

steve-cr

I problemi, purtroppo, sono solo per voi in Italia (causati da dogana e poste), negli altri paesi le consegne avvengono in tempi normalissimi (7/10 gg).....
Non sapevo che anche tu fossi all'estero!

Comunque ho sperimentato da poco l'acquisto dei componenti elettronici, resistenze smd, condensatori, ULN2003 e altri semiconduttori. Nessun problema. Tutto perfetto.
E pensare che fino a poco fa andavo su RS con tutti i problemi che ho con la dogana Canaria quando il pacco supera i 150 euro.....
Samantha Cristoforetti: "Mi fai fare un giro sul tuo ultraleggero?". "Certamente, però piloto io !"

tech2019

Pensavo di nuovo di far funzionare il mio relè (primo messaggio di pagina 1) con la mia scheda che ha uscite digitali a 3.34 V;
Avendo a disposizione un fotoaccopiatore PC817, ho pensato di collegare il pin di segnale (di arduino) ad una resistenza di circa 1K collegare poi quest'ultima all' anodo del PC817 e il catodo del PC817 al GND; il collettore, l'ho collegato al 3.3V e l'emettitore al pin di ingresso segnale della scheda relè.
Pensavo quindi che quando veniva dato il segnale alto da arduino il fotoaccopiatore faceva passare la 3.3V che portando tensione al pin di ingresso del modulo relè l'ho avrebbe attivato viceversa quando c'era segnale basso il relè non ricevendo alcun segnale si disattivava. Ho testato il tutto ma non funziona; il modulo relè non si attiva proprio.
Eppure se collego a mano il pin di segnale del modulo relè alla 3.3V e alla 5V rispettivamente il relè si attiva e disattiva. Perchè allora con il fotoaccoppiatore non funziona?

maubarzi

Il PC817 ha una Ic di 50mA, forse non è sufficiente, i relè che ho io ne richiedono da 70 a 100.
In genere dopo il fotoaccoppiatore ci si mette un transistor che fornisce la corrente necessaria.
Prendendo uno schema in prestito dalle schede già pronte, qualcosa del tipo:
Nessuna buona azione resterà impunita!

Preistoria -> medioevo -> rinascimento -> risorgimento -> rincoglionimento!

tech2019

Forse mi sono spiegato male, l'emettitore del fotoaccoppiatore l'ho collegato al pin di comando della scheda relè non l'ho usato per collegarlo direttamente alla bobina .....semplicemente sto simulando quello che faceva la porta digitale.di.arduino con il fotoaccoppiatore.
Pero la scheda relè rimane sempe spenta. Dopo posto uno schemino di quello che ho fatto.

miky_police

non è che ti sei spiegato male, ma maubarzi ti ha detto come puoi aggirare il problema della limitata corrente del OC.
ovviamente dove si vede il jumper vcc che va ponticellato devi alimentare a 5v che dubito che non è presente sul clone R3. Anche perché se non fosse presente perdi la compatibilità con una infinità di shield, il che porterebbe a non comprare quel clone a prescindere dal prezzo.
Il vero stupido è colui che fa e rifa la stessa cosa aspettandosi risultati diversi. A.E.

tech2019

Il PC817 ha una Ic di 50mA, forse non è sufficiente, i relè che ho io ne richiedono da 70 a 100.
In genere dopo il fotoaccoppiatore ci si mette un transistor che fornisce la corrente necessaria.
Prendendo uno schema in prestito dalle schede già pronte, qualcosa del tipo:

In allegato lo schema di quanto ho fatto.


Claudio_FF

Il collettore del PC817 va ai +5V, altrimenti sei come prima, anzi peggio perché ci si mette in mezzo anche la caduta di tensione del transistor.
********* IF e SWITCH non sono cicli ! *********
**** Una domanda ben posta è già mezza risposta ****
*** La corrente si misura in mA, la quantità di carica in mAh ***

maubarzi

e oltretutto vanifichi il vantaggio della separazione elettrica fornito dall'accoppiatore ottico.
Nessuna buona azione resterà impunita!

Preistoria -> medioevo -> rinascimento -> risorgimento -> rincoglionimento!

Go Up