Go Down

Topic: SOLVED - Cannot upload on Win7 x64 machine (But can under XP 32) (Read 907 times) previous topic - next topic

Lasivian

May 14, 2011, 10:09 am Last Edit: May 14, 2011, 11:32 am by lasivian Reason: 1
I tried running Version 0021 and it worked without a hitch. Left this here for documentation, maybe it'll help someone else :)

------ ----- ------ ----- ------ ----- ------ -----

Beware, I believe I am far into non-newbie troubleshooting territory here.

So, info, I have 4 new arduino Duemilanoves with 328P chips on them (3 from one source, 1 from another) and an FTDI communication board that is giving the same issue.

I plugged 2 of the Arduinos into my friends XP 32 machine with 0022 and uploaded blink to them just fine.

I use the same cables to plug them into my Windows7 x64 machine and I get 3 RX blinks, no TX activity and

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

Yes I have the right board selected.
The FTDI driver is being found automatically, the 0022 driver is not considered an upgrade by the OS.
The com port seems to change based on which of the Duemilanoves i'm plugging in.
I am trying both the drivers in the 0022 software pack and this drive: http://www.ftdichip.com/Drivers/CDM/CDM20814_WHQL_Certified.zip Both give the same error.
I tried re-burning the bootloader on one of the arduinos with a USBTinyISP which worked but still get the same response via USB communication attempts, attempts to load sketches via ISP from the Win7 machine have worked.
I'm not running any "blocking" software like Zonealarm, Windows Firewall, etc.
I have no problem devices in Device Manager at all, I'm running this motherboard: http://www.newegg.com/Product/Product.aspx?Item=N82E16813130276 and have not had any other USB issues to date.
I've tested multiple different USB MB ports.

I'm at the point of "no idea what else to test" frankly. Any suggestions?

Thanks.

Go Up