Go Down

Topic: Tools don't show up in arduino IDE 1.8.5 [SOLVED] (Read 3708 times) previous topic - next topic

forkliftcat

Jul 29, 2018, 01:25 pm Last Edit: Jul 29, 2018, 03:15 pm by forkliftcat
Dear arduino wiese ones,

I tried to install the EspEsceptionDecoder https://github.com/me-no-dev/EspExceptionDecoder as a tool but whatever I do, it doesn't show up in the tool menu of the arduino IDE 1.8.5

System: Windows 10
Arduino IDE version: 1.8.5

What I tried:

Unpacking to:
C:\Users\#Username#\Documents\Arduino\tools\ (this is my sketsch folder)
Full path looking like:
C:\Users\#Username#\Documents\Arduino\tools\EspExceptionDecoder\src

I also tried to rename "src" to "tool"


I also unpacked it to
C:\Program Files (x86)\Arduino\tools

(the WiFi101 tool is there and it's the only tol that shows correctly on the menu)


I tried several other tools in case it's an issue of the EspExceptionDecoder, but it doesn't seem to be. Whatever tool I try to install, it doesn't show...

Any ideas?






forkliftcat

#3
Jul 29, 2018, 01:38 pm Last Edit: Jul 29, 2018, 01:39 pm by forkliftcat
Thank you for the fast reply. I think I did all that. I also restarted the IDE and also my complete system several times.
So you can confirm it works with IDE 1.8.5?
Do you see where I overlooked/not followed the instructions? 

forkliftcat

The only trouble I see is that the instruction talks about getting a .jar file out of the extraction:

<home_dir>/Arduino/tools/EspExceptionDecoder/tool/EspExceptionDecoder.jar

But when I extract it I get a .java

<home_dir>/Arduino/tools/EspExceptionDecoder/src/EspExceptionDecoder.java

I'm willing to learn where I go wrong and I sure wouldn't ask if the solution was obvious to me.


forkliftcat

*Epic facepalm*
Thank you so much, that solved it! Clear case of problem was between computer and chair.


Vitalicus


Go Up