Go Down

Topic: Uploading project - receive error  (Read 165 times) previous topic - next topic



First timer here, so I will do my best to provide as much info to describe my issue.

Error that I get when uploading:  /home/jc/.arduino15/packages/arduino/tools/avrdude/6.0.1-arduino5/bin/avrdude: error while loading shared libraries: libreadline.so.6: cannot open shared object file: No such file or directory

OS: Ubuntu 18.04

Arduino: 1.8.10

Device:  Arcbotics Sparki 

Following the path that is described above I do see the file avrdude and I can see that I have libreadline.so.6 in my usr folder.

I have searched the error and seen a few results, but I cant say that I see something that is related to my issue.

As a new user of Arduino I had several other error, permissoins etc that I have solved, but stuck on this one.

I have tried installing the Snap from Ubuntu, the download from Arduino as well as run both from my account and sudo.  To me this seems to be a visibility issue from the systems, as it states that it cant find it, when it is there, or I am not reading the error correct - as it also is looking for a shared item, but what is that shared item?

Thank you for you time.


Go Up