Go Down

Topic: Cannot install v 1.8.9 on Raspberry Pi 3 (Read 430 times) previous topic - next topic

teesabo

v 1.8.9

Im trying to install this version of the IDE on a raspberry pi 3 64 with the raspbian OS, which appears to be a version of Debian. it has the GPU set at 128.  I follow the instructions, that is, download the compressed file, extract a tar that gets extracted into the files, I run the ./install.sh, and then it has two errors:

 pi@raspberrypi:~/Downloads/arduino-1.8.9 $ ./install.sh
Adding desktop shortcut, menu item and file associations for Arduino IDE...
rm: cannot remove '/usr/local/bin/arduino': Permission denied
Removing symlink failed. Hope that's OK. If not then rerun as root with sudo.

rm: cannot remove '/usr/local/bin/arduino': Permission denied
Removing symlink failed. Hope that's OK. If not then rerun as root with sudo.

ln: failed to create symbolic link '/usr/local/bin/arduino': File exists
Adding symlink failed. Hope that's OK. If not then rerun as root with sudo.
 done!


So when I click on the icon, it doesnt do anything.
Ive tried this with sudo, sudo -i to address the permission issue, same thing.

Can anyone advise what I am doing wrong ? (BTW did install it on a windows 10 laptop, no problem).

Many grateful thanks from me and my son.

pert

download the compressed file
Which download? You need to use the "Linux ARM 32 bits" link on the software page, not the "Linux ARM 64 bits" link. That has been the source of confusion for some people recently.

Go Up