Go Down

Topic: Complete Installation problems!! (Read 161 times) previous topic - next topic

angbrs

From the beginning, the Arduino IDE does not recognize the UNO board. Mu UNO does not have a green on light, but instead has a red solid light next to a marking that reads ON, and a blinking red light next to a marking that reads L. 

I the board was recognized when I plugged it into the USB at COM 7 not as an Arduino.  I searched for drivers and noted it recognized the UNO as USB SERIAL CH340.  (Board came as part of an inventer kit that shipped from China)   I unchecked show compatible hardware and pointed it to the Arduino driver folder with the arduino.inf file. After driver update, I check the driver details and see the driver folder is not an arduino folder but in a Windows driver file



C:\Windows\system32\DRIVERS\usbser.sys

  I also cannot upload the example blink to the board, getting the error message:

avrdude: ser_open(): can't set com-state for "\\.\COM7"

I tried copying the arduino.inf file to a created folder with nothing else in it and browsing to that folder for driver location, and the driver details still read as above even after Windows says it was successful in installing the driver.



So, I have successfully named the device Arduino UNO, but do not think the correct driver is installed.

pert

Official Arduino boards do not use the CH340, so drivers for that chip are not provided with the Arduino IDE. The board you bought is not a real Arduino Uno, but instead a derivative board of the Uno, which will work in a similar way, other than needing a different driver. You need to download and install the CH340 driver from the manufacturer's website:
http://www.wch.cn/download/CH341SER_ZIP.html

After that, you should see a COM port appear in the Arduino IDE's Tools > Port menu after you plug in your board.

I don't understand or know what the effect will be from all that other weird driver stuff you did.

Go Up