Go Down

Topic: Cannot get any Arduino sketch to run (Read 190 times) previous topic - next topic

tutu10

Hi,
I tried this with MacOs 10.11, with Win7, Win10 and Arduino IDE 1.6.7, 8 and 9
Board package is 2.9, Duo FW is 0.21.
Board Type set correctly, port available and selected correctly.
Opening any Duo Sample sketch and click upload.
Sketch compiles fine, led on Duo flickers, uploading progress ok.
Upload completes w/o error.
Duo reboots…
Sketch is NOT running. E.g blinking sample or RGB-Sample…no reaction…led blinks 500ms blue…as it does always
E.g BLE scan (with serial out)…no reaction.
Tried uploading FW. Put device in DFU. No matter if I use dfu-util or IDE…always get dfu suffix error.
Has anybody an idea ? Help

ballscrewbob

Do you mean the Arduino "DUE" ?

Moving you to that section anyway.

Bob.
It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

pjrc

Do you mean the Arduino "DUE" ?
Might be a RedBear's STM32-based product, which is indeed named "Duo".

https://github.com/redbear/Duo/blob/master/docs/getting_started_with_arduino_ide.md

The info for this "Duo" board would also explain why using Arduino 1.6.x

Go Up