Go Down

Topic: Now this may be REALLY weird! (Read 201 times) previous topic - next topic

scintilla

Hello again,
Having fixed all my previous problems (thanks to this forum) I have been busily printing stuff for my new CNC 6040 Mach3 Mill. All appeared to be working well. Until...

Firstly, when printing a fairly large object the Slic3r, the time estimate was for 2 Hrs but, after about ten minutes, the Effector began to traverse the bed more and more slowly.
The timer ran with longer and longer gaps between updates. After 2 Hrs I quit the printing when it was only half done.

I had noticed, while doing some smaller prints just before this event took place, that the Effector has somewhat 'jittery' on the first (0.35mm) layer. This seemed to smooth out on the second layer (0.3mm). Temperatures printing PLA were 195C and Ultrabase was set to 60C. Nozzle is 0.4mm.

I fired up the trusty Pronterface program to check the geometry. All measurements on the Pronterface bed are still precise, the print plane is dead flat (I manually set the delta parameters on my Anycubic Kossel Delta Plus), and the distance moved on command are very precise.

Secondly, now when I try to print anything from my Arduino 1.6.0 IDE (yep, I have tried several other iterations of Arduino / Marlin with the same following results) the Effector descends to the bed, jumps on the first movement, runs in inconsistent, sometimes crazy leaps, and then misses steps. Of course the print is rubbish so I have to hit the kill button.

It seems to my analysis that there is nothing wrong with the RAMPS board, steppers or USB connections because the Pronterface test gives perfect results.

I suspect there is something going on in the Arduino communication timing or with the Slic3r program. I have run my .stl files through NetFabb on the off chance that it's a file issue but the results are identical.

I am really puzzled by the slower and slower running of the print. I always thought the programs would either run or stop. It's as if the clock is running at some sort of disrupted pace. There is no discernible mechanical load buildup.

The print plane when the print is running is now tilted from being dead flat so there are definitely steps going astray somehow

Don't you just LOVE a good mystery? I will scour the forum for a similar thread but, so far, nothing like this has shown up.

I just thought of trying a different slicer program, such as Cura, so I will let you know if I have any luck. I'm not optimistic...

As ever, your thoughts would be really welcome.

Scintilla (yet again  :) )

AWOL

#1
May 08, 2019, 10:11 am Last Edit: May 08, 2019, 10:12 am by AWOL
Have you posted in the wrong forum?

scintilla

I don't know.

If this isn't troubleshooting, I don't know what is.

Perhaps you could usefully direct me to the 'right' forum.

Thanks,

Scintilla

scintilla

There seems to be some sort of speed reading problem here.

I thought I was pretty clear when I said in my original text   ...'busily printing stuff FOR my new 6040 CNC machine'...  not 'ON' my CNC machine. I did re-read it a couple of times to try not to bog down in too much detail

Any reasonable reading would show that this post is only about Arduino and my AnyCubic printer.

I hope this meets with the Forum's high 'relevance' standard. ( apparently set by someone who 'doesn't give a rat's anyway' ).

Maybe someone who has actually experienced such an Arduino-related phenomenon might care to share it with the rest of us.

Let's all take a deep breath and continue being part of the friendly forum. :)

Cheers,
Scintilla.

BJHenry

Is that last post related to a post somewhere else? It seems to have come out of nowhere.
I think AWOL was trying to suggest that you would get better answers on an AnyCubic or 3D Printing forum, since all the control hardware (IE the Arduino part) seems to be functioning.

scintilla

Hi Everyone,
Yes, this came out of nowhere. To clarify;
I responded to a rather snitty and inaccurate message from 'Coffee Bean' who was apparently put out because he though I was referring to a CNC machining issue.
It is clear that I was not. I pointed out his misreading of my issue. He graciously apologised.

I assumed my reply would have had his message to me included, hence the 'out of nowhere' appearance. I will take this lesson on board for the future. I don't want to waste the Forum's time and goodwill on mere misunderstandings.

I feel that my original post was correctly aimed at the Troubleshooting knowledge base, simply because it involves a version of Arduino which 'almost' works, after working perfectly previously.
 
The fact that Pronterface still works perfectly would indicate a cause isolated to Arduino or, possibly, Slic3r.

My plan, for what it's worth, is to remove all traces of my current Arduino software and reinstall from scratch. Maybe a file has been mangled during a dreaded Windows Update  :smiley-confuse: ('trust us, folks, we will fix everything for you...' )
Maybe a System Restore to a time when everything worked might be another approach.

This is the only way my limited troubleshooting ability would be likely to give a clue as to what's going on.
I will have another look through the AnyCubic and 3D Forums but this problem seems to be Arduino specific. It's clear that the RAMPS board and Stepper Drivers are all functioning perfectly well with Pronterface.

I am really happy to be re-directed to a more-appropriate Forum, if one exists, so please feel free to comment. I am a novice after all.

I really hope everything is clear now. It's a very interesting puzzle and I will be keen to share the solution if I can find it.

Thanks again,
Scintilla.


Go Up