Go Down

Topic: Wav Files Won't play (Read 176 times) previous topic - next topic

CathyMac

Hi,
I've been having trouble playing audio from my arduino uno via SD card. I seem to be able to play the EXAMPLE.AFM files but my own files changed to wav, 8 bit, 16000hz, mono, un-signed 8-bit still wont play at all.
 
Below are the components I am using:

- 8Ohm Speaker

- DollaTek LM386 Audio Amplifier Module 200 Times 5-12V 10K Adjustable Resistance
- Arduino Uno

-HiLetgo 5pcs Micro SD TF Card Adater Reader Module 6Pin SPI Interface Driver Module with chip level conversion for Arduino UNO R3 MEGA 2560 DUE

-SD Card 4gb

I'm wondering if anyone has any advice on this? Code Shown Below:

Thanks,
              Cathy



#include <sd_l0.h>
#include <sd_l1.h>
#include <sd_l2.h>
#include <SimpleSDAudio.h>
#include <SimpleSDAudioDefs.h>

#include <SimpleSDAudio.h>

void setup() {

SdPlay.setSDCSPin(10); // sd card cs pin

if (!SdPlay.init(SSDA_MODE_FULLRATE | SSDA_MODE_MONO | SSDA_MODE_AUTOWORKER))

{ while(1); }

if(!SdPlay.setFile("EXAMPLE.AFM")) // music name file

{ while(1);

}

}

void loop(void)

{

SdPlay.play(); // play music

while(!SdPlay.isStopped())

{ ;

}

}

SchnoppDog

Hello Cathy
I am sorry but I can't look it up right now. Never used this Library. But I strongly recommend reposting your question with the forum's rules look here.

Please keep in mind to post your code in code-tags. Link your Hardware you used, don't just write what you use. Also tell us which library you use also what Code worked to play the sound files.

Go Up