Go Down

Topic: Arduino 101 Executing command: exec: not started (Read 270 times) previous topic - next topic


May 15, 2019, 06:59 pm Last Edit: May 15, 2019, 10:47 pm by awittman
I am currently attempting to run a sketch on an Arduino 101 embedded on a Udoo board. The Udoo is running Ubuntu 18.04.2 LTS Bionic. Web browser is Mozilla Firefox 66.0.5.

I attempted to run through the Arduino IDE but it did not have my board listed and therefore would not connect. My next step was to try running through Arduino Create as it has the cores for all boards. I installed the plugin and entered a simple sketch from a tutorial: http://osoyoo.com/2018/11/arduino-lesson-voltage-sensor-module/

When I try to "Upload and Save" a notification pops up that says "Arduino/Genuino 101 Disconnected" and the error: Executing command: exec: not started. Another status then pops up that says "Arduino/Genuino 101 Connected". The output window shows:

/home/builder/opt/arduino-builder/arduino-builder -compile -core-api-version 10611 -hardware /home/builder/opt/arduino-builder/hardware -hardware /home/builder/.arduino15/packages -tools /home/builder/opt/arduino-builder/tools -tools /home/builder/.arduino15/packages -built-in-libraries /home/builder/opt/libraries/latest -logger humantags -fqbn Intel:arc32:arduino_101 -build-cache /tmp -build-path /tmp/638114960/build -verbose -prefs runtime.tools.openocd.path=/home/builder/.arduino15/packages/Intel/tools/openocd/0.9.0+0.1 -prefs runtime.tools.sketchUploader.path=/home/builder/.arduino15/packages/Intel/tools/sketchUploader/1.6.2+1.0 -prefs runtime.tools.nrf5x-cl-tools.path=/home/builder/.arduino15/packages/arduino/tools/nrf5x-cl-tools/9.3.1 -prefs runtime.tools.avrdude.path=/home/builder/.arduino15/packages/arduino/tools/avrdude/6.3.0-arduino8 -prefs runtime.tools.core2-32-poky-linux.path=/home/builder/.arduino15/packages/Intel/tools/core2-32-poky-linux/1.6.2+1.0 -prefs runtime.tools.i586-poky-linux-uclibc.path=/home/builder/.arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0 -prefs runtime.tools.linuxuploader.path=/home/builder/.arduino15/packages/arduino/tools/linuxuploader/1.5.1 -prefs runtime.tools.x86-linux-gcc.path=/home/builder/.arduino15/packages/arduino/tools/x86-linux-gcc/7.2.0 -prefs runtime.tools.arc-elf32.path=/home/builder/.arduino15/packages/Intel/tools/arc-elf32/1.6.9+1.0.1 -prefs runtime.tools.dfu-util.path=/home/builder/.arduino15/packages/arduino/tools/dfu-util/0.9.0-arduino1 -prefs runtime.tools.CMSIS-Atmel.path=/home/builder/.arduino15/packages/arduino/tools/CMSIS-Atmel/1.2.0 -prefs runtime.tools.arm-linux-gcc.path=/home/builder/.arduino15/packages/arduino/tools/arm-linux-gcc/4.9.3 -prefs runtime.tools.arduino101load.path=/home/builder/.arduino15/packages/Intel/tools/arduino101load/2.0.1 -prefs runtime.tools.arduinoOTA.path=/home/builder/.arduino15/packages/arduino/tools/arduinoOTA/1.2.1 -prefs runtime.tools.bossac.path=/home/builder/.arduino15/packages/industruino/tools/bossac/1.7.0-industruino -prefs runtime.tools.CMSIS.path=/home/builder/.arduino15/packages/arduino/tools/CMSIS/4.5.0 -prefs runtime.tools.arm-none-eabi-gcc.path=/home/builder/.arduino15/packages/arduino/tools/arm-none-eabi-gcc/7-2017q4 -prefs runtime.tools.flashpack.path=/home/builder/.arduino15/packages/Intel/tools/flashpack/2.0.0 -prefs runtime.tools.avr-gcc.path=/home/builder/.arduino15/packages/arduino/tools/avr-gcc/5.4.0-atmel3.6.1-arduino2 -libraries /tmp/638114960/custom -libraries /tmp/638114960/pinned /tmp/638114960/sketch_may15a

Sketch uses 17632 bytes (11%) of program storage space. Maximum is 155648 bytes.

Programming with: Serial

Restarting in bootloader mode

Get port list before reset


Touching port /dev/ttyACM0 at 1200bps

Set DTR off

Flashing with command:/home/myuser/.arduino-create/Intel/arduino101load/2.1.0/arduino101load -dfu=/home/myuser/.arduino-create/arduino/dfu-util/0.9.0-arduino1 -bin=/tmp/arduino-create-agent547521223/sketch_may15a.bin -port=/dev/ttyACM0 -v -ble_fw_str=ATP1BLE00R-1631C4439 -ble_fw_pos=169984 -rtos_fw_str= -rtos_fw_pos=0 -core=2.0.0

Set DTR off

Flashing with command:/home/dendemo/.arduino-create/Intel/arduino101load/2.1.0/arduino101load -dfu=/home/dendemo/.arduino-create/arduino/dfu-util/0.9.0-arduino1 -bin=/tmp/arduino-create-agent547521223/sketch_may15a.bin -port=/dev/ttyACM0 -v -ble_fw_str=ATP1BLE00R-1631C4439 -ble_fw_pos=169984 -rtos_fw_str= -rtos_fw_pos=0 -core=2.0.0


I can reproduce the issue, but only intermittently. I'm also able to successfully upload to the 101 occasionally. Is it the same for you?


I am unable to upload to the board at all although I have only tried 20-30 times so it is still possible that it is an intermittent problem.


May 16, 2019, 05:35 pm Last Edit: May 16, 2019, 05:37 pm by ballscrewbob
The 101 boards can be extremely fussy.

There is a strong chance it is not any of the IDE's but can often be the USB cable length / quality.

Of all my USB cables only about half of them work with the 101 despite being both DATA and POWER.

They also seem to especially hate USB 3.0 more than the other boards.


PS. The "touching port" issue has also raised its ugly head on the desktop IDE and is not confined to CREATE.

It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.


It turns out I needed to install Arduino IDE manually. The version that is obtained via apt-get on Ubuntu is outdated and does not include the board manager. Still not working on Create, but I'm happy with it working on the IDE.

Thanks for the responses!


I reported the problem with the "Executing command: exec: not started" error when uploading to an Arduino 101 in the Arduino Web Editor to the Arduino developers and they have already made a fix! If you still have the problem, try clearing your browser cache.

Thanks so much for bringing this to our attention awittman!

Go Up