Go Down

Topic: MKR GSM 1400 hangs! (Read 719 times) previous topic - next topic

zeroone

Hello,
i always got a hanging problem at the MKR GSM 1400, i tried by power off-on the system, or trying to move the SIM little forward/ backward / left / or right within its place when the system is off, sometimes it worked and sometimes it is not.

the gsm access check was at the setup:

Code: [Select]

  while (!connected) {
    if (gsmAccess.begin(PINNUMBER) == GSM_READY) {
      connected = true;
    } else {
      Serial.println("Not connected");
      delay(1000);
    }

.
now I moved the gsm access to check at the loop and also activate the debug as follows:
Code: [Select]

#include <MKRGSM.h>

#include "arduino_secrets.h"
const char PINNUMBER[] = SECRET_PINNUMBER;
// initialize the library instance
GSM gsmAccess=1;
GSM_SMS sms;
bool connected = false;

void setup()
{
  Serial.begin(9600);
  while (!Serial)
  {
    ;
  }
}

void loop()
{
  Serial.println("SMS Messages Sender");
  if (!connected)
  {
    if (gsmAccess.begin(PINNUMBER) == GSM_READY) connected = true;
  }
  else
  {
    Serial.println("Not connected");
    delay(15000);
  }
}


and also hangs but I attached the logs.

notes:
- the SIM is working normally, i have tested it at SIM800c and also a phone.
- i have tested the at different GSM 1400 MKR devices.
- it seems there is a problem at the GSM library, yesterday i have downloaded an update for the library but the same problem

any suggesstions?

thanks

pert

Do you have a 1500 mAh or higher LiPo battery connected to your MKR GSM 1400?

zeroone

Do you have a 1500 mAh or higher LiPo battery connected to your MKR GSM 1400?
no, just with USB power and also a VIN 5 V 2 A

zeroone

I have an update:
I have tried another SIM from another provider and it is worked fine, I have attached an image for both SIMs.
my question, does it matter the SIM structure for Ublox modem of the MKR GSM 1400?

thanks

zeroone

Hello,
after I have contacted Arduino support, they have informed:
Quote
Its a known issue of hangs because with the current hardware and software revision, the minimum reachable current consumption is 20mA (the level transistor consumes ~10mA each in every condition). However, we are working to achieve the best performances.
and also:
Quote
The MKR GSM 1400 board hangs time to time and its a known issue. I am talking generally on the MKR GSM 1400 board issue. 
We are waiting for the answer to this issue.
they will do a refund for the products.
I hope to be solved quickly, so there is a new hardware version for the MKR GSM 1400!


PhysicsUofRAUI

I am having this issue as well. Is it known to be a software issue or is it a hardware issue?

Cheers,

pert

Based on your description, I can't say for sure if it's relevant to your problem, but you might read these recommendations on the use of the MKR GSM 1400 from the Arduino developers and see if it can be helpful to you:
https://github.com/arduino-libraries/MKRGSM/issues/66#issuecomment-498981034

devyani

I'm having the same hang issue. Is this issue solved?

PhysicsUofRAUI

I am having this issue as well. Is it known to be a software issue or is it a hardware issue?

Cheers,
My problem went away after I added an antenna. This was the antenna I used https://www.amazon.ca/gp/product/B00N4YMMTG/ref=ppx_yo_dt_b_asin_title_o05_s00?ie=UTF8&psc=1

kickouille

PhysicsUofRAUI,

Are you saying you didn't have any antenna connected?

As a general rule, always has a load like an an antenna connected to an RF system, else all power is reflected back to the chip and may fry it.

Concerning this hanging issue, I did also a lot of troubleshooting, and noticed I was always stuck at:
gsmAccess.begin(PINNUMBER)

By default, it is in sychronous mode, meaning that ones we enter this method, it will wait for a connection to the carrier. If none happens, it wil indefinitely stay in there.
If you want to have control on this or eventually execute something else while it is loking at the carrier, then go in asynchronous mode, and methos will return after every check.

This is documented here.

LTE-M and NB-IoT coverage in my area is bad, I was hitting my head on the walls before realizing this, and though I was having SW or HW issues...

Go Up