Go Down

Topic: avrdude: verification error; content mismatch (Read 91 times) previous topic - next topic

Lawrence2002

May 19, 2019, 04:15 am Last Edit: May 19, 2019, 04:17 am by Lawrence2002
I have been using an Uno to program my Arduino Pro-mini and it was working perfectly fine with uploading code, but it now keeps popping up with an error message. The green LED blinks green when it is on and i have tried holding down the reset button when uploading but it still does not work. I am pretty new to coding and programming and I do not really understand what to do and when I tried to do some research I was at a lose. Thank you for your help.

Sorry I just realized I posted this in the Project Section.

Error message:

Arduino: 1.8.9 (Mac OS X), Board: "Arduino Pro or Pro Mini, ATmega328P (5V, 16 MHz)"

Sketch uses 930 bytes (3%) of program storage space. Maximum is 30720 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.
avrdude: verification error, first mismatch at byte 0x0000
         0xff != 0x0c
avrdude: verification error; content mismatch
avrdude: verification error; content mismatch

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Robin2

How is the Uno connected to the Pro Mini ? - please post a simple pencil drawing showing the connections. See this  Simple Image Guide


What program is on the Uno?

Have you tried disconnecting and reconnecting the Uno from its power supply?
Likewise for the ProMini.

How is the ProMini powered while programming

Have you tried re-loading the program onto the Uno?

Have you checked that there is no loose connection - especially for GND?


Nick Gammon's diagnostic program may help

...R
Two or three hours spent thinking and reading documentation solves most programming problems.

Lawrence2002

Here is a picture of my set up and the other is a diagram to the pins that I have connected. I have tried unplugging then plugging back in the power supply on both the pro mini and the uno and the same error pops up. I do not know the program that is on the Uno, but I was able to program the pro mini with the same connections with the Uno but then it stopped working and it now pops up with that avrdude error. I have tried using different wires and an FTDI and the message still pops up. Thank you for your time.

Lawrence2002

The images didn't attach so I found this one that is slightly how I set mine up. The only difference is instead of putting the GND to Reset on the Uno, I put the reset from the Uno to the GRN on the Pro mini.


pert

#4
May 19, 2019, 08:17 pm Last Edit: May 19, 2019, 08:18 pm by pert
How are the wires physically connected to the Pro Mini?

Lawrence2002

I used male to female wires from the Uno to the Pro mini.

Go Up