Go Down

Topic: When Arduino Uno is plugged in Windows computer sees it as "ATmega16u2 DFU" (Read 218 times) previous topic - next topic

cosmo11cosmo

I just got my arduino uno today, and after going through my starter kits instructions i've ran into a roadblock in having my Windows 10 computer recognize the arduino UNO. I have tried manually installing the drivers using the drivers folder in the ZIP version and Windows installer version of the IDE and neither change anything, it just keeps seeing the board as ATmega16u2 DFU in device manager under the other devices panel. I have tried resetting my computer and uninstalling the Arduino device to see if anything changed, and repeated the process. The drivers won't install.

Sidenote: is it significant at all that when its plugged into my computer, (and the 13LED turns on as well as the ON LED.) and I click the reset button nothing happens?

DrAzzy

Looks like you got one of those without the firmware on the atmega16u2 that's used as serial adapter. Either return it, or use Atmel FLIP to write the firmware file to it. There's been a few of those making the rounds lately.

I think the file is this one: (arduino install location)\hardware\arduino\avr\firmwares\atmegaxxu2\arduino-usbserial\Arduino-usbserial-atmega16u2-Uno-Rev3.hex
ATTinyCore for x4/x5/x61/x7/x8/x41/1634/828/x313 megaTinyCore for the megaavr ATtinies - Board Manager:
http://drazzy.com/package_drazzy.com_index.json
ATtiny breakouts, mosfets, awesome prototyping board in my store http://tindie.com/stores/DrAzzy

pert


Go Up