Go Down

Topic: Problems with the uploads (Read 1 time) previous topic - next topic

numlo

Hello,

I have a serial single sided Arduino with an Atmega8-16PU. It does not work anymore and I hope some of you might have some suggestions.

My normal routine was to upload the bootloader with the parallel programmer and the code with the serial port.

A few days ago the bootloader upload stopped working. The serial sketch upload kept working fine for the chips with the bootloader installed.

I got the following error:
Quote
avrdude: AVR device not responding
avrdude: initialization failed, rc=-1
avrdude: Yikes!  Invalid device signature.
avrdude: Expected signature for ATMEGA8 is 1E 93 07
avrdude: AVR device not responding
***failed; 
avrdude: verification error, first mismatch at byte 0x0000
         0xca != 0xff
avrdude: verification error; content mismatch


The only thing that I did different from the usual bootloader uploads was having an online radio open. .pls file.
I mention this because I know how sensitive Arduino can be to software like antivirus and disk emulators.
If I burn the bootloader without connecting anything to the Arduino I get the same error so It's like my Arduino board does not even exist to the IDE.

If I connect the parallel programmer to the Arduino and power it, the LED 13 is always on.

Now the serial sketch upload has stopped working for the micro-controllers with bootloaders. Now the RX LED blinks 3 times when I click on the upload button and blinks one more time after a few seconds. 

When I upload a sketch I get this message:

Quote
avrdude: stk500_getsync(): not in sync: resp=0xf8
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0xff


I've tried a lot of the usual things that worked when I had similar problems but this time it seems that it's something else.

Are there any ways to upload the Arduino sketch besides the IDE? I searched with Google but I could not find another software package. I would like to upload the sketch with the parallel programmer.

I had these kind of problems before and after a few days of troubleshooting I get the Arduino to work. Unfortunately for me this time I need to upload a sketch on some Atmegas and I don't have this much time.

numlo

I forgot to mention one other thing. Before it broke down, I was playing with a stopwatch sketch and I noticed that the time was off. One or 2 seconds would display values of 6-9 seconds or even more. After I uploaded again the same sketch without any mods it worked fine.

numlo

I've noticed that if I connect one of the Atmega8 chips to the serial port and open the serial monitor I get all sorts of squares and symbols.

Does anybody know what extension a makefile has?

numlo

When I hold the Shift key before uploading the blink sketch I get this:

Quote
avrdude: Version 5.4-arduino, compiled on Oct 11 2007 at 19:12:32
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

         System wide configuration file is "C:\Documents and Settings\Home\Desktop\arduino-0018\hardware/tools/avr/etc/avrdude.conf"

         Using Port            : \\.\COM1
         Using Programmer      : stk500v1
         Overriding Baud Rate  : 19200
avrdude: ser_open(): setting dtr
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: Send: Q [51]   [20]
avrdude: Recv:
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

avrdude done.  Thank you.


I am trying to use the parallel programmer and I did the mods in preferences.txt including changing the port to LPT1. I don't know why I get the COM1 port there.

Also I got another HDD unit and did a fresh Win XP install and nothing has changed. I get the invalid device device signature message when I try to burn the bootloader and the not in sync message when I try to upload a sketch.

On a fresh chip with no bootloader the pin13 LED is always on when I power the Arduino and connect it to the parallel programmer.

On a chip with the bootloader installed (pin13 LED blinks when I press reset) I get all the 2 LEDs to blink when I power it up and try to upload a sketch.

Any suggestions?

Go Up