Go Down

Topic: Bridge.begin hangs (Read 1 time) previous topic - next topic

sillycow

Jun 10, 2019, 05:17 pm Last Edit: Jun 10, 2019, 05:22 pm by sillycow
I have an old Arduino yun project that I'd like to revive.
I coded it ~2016, and it worked fine.
I pulled out the same device now in 2019 and it does not work anymore.

My openwrt was upgraded a while back: Sun Oct 4 02:29:26 CEST 2015 mips GNU/Linux
As far as I remember, everything worked with this distribution.

The device connects to wlan.
I can ssh into the device and run linux commands
I can burn my project and run it:
 1. Leds work fine
 2. Serial print works fine
I can also burn and run the "YunSerialTerminal" program just fine.

However:
When I run bridge.begin() or console.begin(), my arduino hangs. (linux is still responding on SSH)


I tried bridge.begin(115200)  as suggested on some threads.
I tried long-press-factory reset  as suggested by other threads.
I tried a 60 second delay to let the board warm up (although linux is running, since I can ssh).

However, everything remains the same: My project hangs as soon as I call bridge.begin() or console.begin(). And as stated, everything worked 2.5 years ago on the same board. I have a suspicion, that the hardware might have "decayed" during this period. But I still want to try and debug it if I can.

My questions:
1. Any ideas on what is happening here?
2. Is there some way I can debug my project while it is in the "hanged" state from the SSH connection? To try and find out what is wrong with the bridge?

My arduino project: https://www.youtube.com/watch?v=BT-4n7OKxXw

Go Up