Go Down

Topic: Charge inductive et parasites (Read 999 times) previous topic - next topic

vtec35

ba moi je te dis que ce phenomene de parasitage d'ecran se resoud dans mon cas avec une diode, c'est tout, c etait juste pour apporter ma contribution

bonne journée

Jambe

#16
Sep 18, 2019, 01:14 pm Last Edit: Sep 18, 2019, 01:14 pm by Jambe
Le propos ici c'est de supprimer les parasites venant du circuit en 230VAC et non ceux de la bobine du relais côté courant continu, donc pas de + et de -.

Mettre une diode en parallèle des contacts du relais va permettre le passage d'une demie alternance dans la charge: il n'y aura donc pas coupure. C'est ce que t'explique Henri dans son message précédent.

De plus si tu regardes bien son schéma, la diode de « roue libre » est bien présente en parallèle du « solénoïde »/bobine du relais
Cette dernière ne résoudra pas tout

hbachetti

#17
Sep 19, 2019, 10:53 am Last Edit: Sep 19, 2019, 10:57 am by hbachetti
Quote
Sur ce montage, j avais oublié la diode
On ne le répétera jamais assez : cette diode est indispensable.

Quelques explications à propos de la diode de roue libre ici (avec oscillogrammes) :
alimenter-un-relais-transistor

Voir  1.1. La diode de roue libre


Surtension sur le collecteur du transistor (100V)


Perturbations au niveau alimentation (+/- 15V)

Suffisamment éloquent non ?

Je n'ai pas fait de relevés sur ce qui se passe lors de la commutation d'une charge inductive sur le 230V. Mais j'ai déjà eu des problèmes de plantage d'écran LCD (voir #1), et un condensateur + résistance ou une varistance en parallèle sur la charge permet de résoudre le problème.
Linux is like a wigwam: no Windows, no Gates, and an Apache inside ...

hbachetti

#18
Sep 25, 2019, 07:23 pm Last Edit: Sep 25, 2019, 07:24 pm by hbachetti
J'ai rencontré un nouveau problème de parasite sur ce projet : carillon MP3

Un relais 12V (avec diode de roue libre 1N4148) est utilisé pour mettre sous tension une alimentation à découpage MeanWell 24V 50W, une LRS-50-24.

Aléatoirement, lors de la commutation du relais, l'ARDUINO PRO MINI redémarre.

Si l'alimentation de 50W est sous tension en permanence, aucun problème. Le relais est toujours commandé, ce qui le met hors de cause.

En essayant d'appliquer la recette condensateur + résistance en parallèle sur l'entrée 230V de l'alimentation 50W, cela ne donne aucun résultat. La vérité est ailleurs apparemment.

J'ai essayé par pur hasard de débrancher le convertisseur USB / série de la PRO MINI.
C'est un FTDI FT-232R-3.3V :



Le problème disparaît. Ça se corse ...
Il y a probablement un parasite sur le fil RTS câblé sur le RESET de l'ARDUINO.

Je remplace le convertisseur par un modèle chinois (FT232R) :



Le convertisseur est branché au PC avec un câble USB blindé de 25cm et à la PRO MINI avec des fils GND, RX, TX et DTR très courts : 5cm.
Le problème ne réapparaît pas. Tiens donc ...

Je reprend le FTDI FT-232R-3.3V et je raccourcis le câble de 1.80m à 30cm. Le problème ne réapparaît pas non plus.

L'origine des parasites se cache parfois dans des endroits où on ne les attend pas  :smiley-confuse:
Linux is like a wigwam: no Windows, no Gates, and an Apache inside ...

Gerard68

Bonjour,
Je voudrais revenir sur le schéma donné au 1er post, la protection, que ce soit RC ou varistor, doit-elle être câblée en parallèle de la charge ou en parallèle du contact du relais?

Merci de m'enlever ce doute.

hbachetti

Linux is like a wigwam: no Windows, no Gates, and an Apache inside ...

Gerard68

C'est bien ce que je pensais.
Merci pour ta réponse.

Go Up