Go Down

Topic: Fresh install on Mac, can't install boards (Read 440 times) previous topic - next topic

ipearx

Hi I'm brand new to Arduino, never installed before and trying to install some boards so I can play with the Adiafruit Playground express.

Here's what I've done:
1) Download the Arduino IDE
2) Put in the app folder on OSX 10.4.1
3) Go to boards manager
4) I get the following error in the console:

Quote
https://downloads.arduino.cc/packages/package_index.json file signature verification failed. File ignored
Googling didn't not help. Everyone suggested deleting the preferences file, but it was a fresh install! I did try that of course, but no difference. I then tried the beta IDE 1.9.0 same problem.

Any ideas? Not a good experience so far  :smiley-confuse:

ipearx

Note I can access the file https://downloads.arduino.cc/packages/package_index.json happily in my browser, so it's downloading it fine.

pert

Try this:
  • In the Arduino IDE, click the link on the line following File > Preferences > More preferences can be edited directly in the file. This will open the Arduino15 (or similar name depending on OS) folder.
  • Delete all files and folders under the Arduino15 folder except for preferences.txt. Please be very careful when deleting things from your computer. When in doubt, back up!
  • Restart the Arduino IDE

After that, try your Boards Manager installation again.

ipearx

Try this:
  • In the Arduino IDE, click the link on the line following File > Preferences > More preferences can be edited directly in the file. This will open the Arduino15 (or similar name depending on OS) folder.
  • Delete all files and folders under the Arduino15 folder except for preferences.txt. Please be very careful when deleting things from your computer. When in doubt, back up!
  • Restart the Arduino IDE

After that, try your Boards Manager installation again.
To confirm I have tried that, the same error is given afterwards. I tried restarting the app too before trying again. And making sure I closed the app before deleting the files. I also tried deleting the whole Arduino15 folder.

DBMcDonald

Are you really running OS.X 10.4 (Tiger), or was this a typo for 10.14?
Min spec for Arduino 1.8.9 is OS.X 10.8 (Mountain Lion)

ipearx

Are you really running OS.X 10.4 (Tiger), or was this a typo for 10.14?
Min spec for Arduino 1.8.9 is OS.X 10.8 (Mountain Lion)
Sorry yes typo 10.14.1

pert

Are you behind a corporate firewall? Someone had this same problem when their firewall was injecting a warning into the downloaded file.

DBMcDonald

Out of curiosity did some Googling and there is some indication that it could be a router PPPOE problem.  Disabling PPPOE may resolve it.  It can't hurt to try.

ipearx

Are you behind a corporate firewall? Someone had this same problem when their firewall was injecting a warning into the downloaded file.
I've done some testing and got it working by connecting to my mobile phone. So yes my internet connection has something to do with it. It is just a home internet connection, so this shouldn't be a problem. Thanks for the idea.

pert

#9
Jun 16, 2019, 02:12 pm Last Edit: Jun 17, 2019, 01:29 am by pert
I'm glad to hear you have managed to narrow down the cause of the problem a bit at least. Please let us know if you make any further progress, as that information could be useful to others who have the same problem. Here's another two people having the same problem right now:
https://forum.arduino.cc/index.php?topic=621637
and maybe another here:
https://forum.arduino.cc/index.php?topic=621811

pert

I think we're starting to make some progress on this issue in one of the other threads. It would be helpful if you would do something for me:


I'll check out your files and see if you're having the same problem as Cheetor is reporting in the other thread. Once we have the problem narrowed down and confirmed, I'll report it to the people at Arduino who can investigate further.

pert

Two out of the four people with the issue are located in New Zealand (I don't know about the other two). It might be helpful to the investigation to know your general geographic location. If you don't want to share that information I understand.


rsora

Hi there,
we launched a CDN refresh, can you please verify if you are still experiencing the
"package_index.json file signature verification failed. File ignored"
error?
If yes please reply with geographical location and both headers and files.
Thanks!
Arduino Team Engineer

Go Up