Go Down

Topic: IRrecvDemo returning same value when no button pressed (Read 208 times) previous topic - next topic

knovoselic

Hi all!

I'm trying to get my IR receiver working. I'm using Arduino 1.8.9 and IRremote by shrriff 2.2.3.
My first step was trying out IRrecvDemo, but this is where I'm stuck and I'm not sure how to proceed. On the serial output I'm always getting E6B4CDFE value (it prints every 100ms). If I press a button on the remote, then I get FFFFFFFF. So this is how my output looks:


Code: [Select]
E6B4CDFE
E6B4CDFE
E6B4CDFE
E6B4CDFE
E6B4CDFE
E6B4CDFE
FFFFFFFF
E6B4CDFE
FFFFFFFF
E6B4CDFE
FFFFFFFF
E6B4CDFE
E6B4CDFE
FFFFFFFF
E6B4CDFE
FFFFFFFF
E6B4CDFE
E6B4CDFE
E6B4CDFE
E6B4CDFE
E6B4CDFE
E6B4CDFE
E6B4CDFE
E6B4CDFE
...


Any idea what's wrong? How do I debug this? This should be pretty simple...

I'm using TSOP4838, connected Signal to pin 7, GND to GND and VIN to 5V. Also tried 3.3V, and got the same result.

As for debugging, I've also tried a different IR receiver - KSM-2012TE2s and got the same result.
All of this was tested on my Arduino uno. Also tried it with Arduinu Nano - no luck, the same result.


Any ideas?

vaj4088

Maybe someone else can help.  I cannot help if there is no code and no wiring diagram.


larryd

You need to do two things:

1.
Show us a good schematic of your circuit.
Show us a good image of your wiring. 
Give links to components.
Posting images: 
https://forum.arduino.cc/index.php?topic=519037.0

2.
Use CTRL T to format your code.
Attach your 'complete' sketch between code tags, use the </> icon in the posting menu.
[code]Paste your sketch here[/code]






No technical PMs.
If you are asked a question, please respond with an answer.
If you are asked for more information, please supply it.
If you need clarification, ask for help.

Go Up