Go Down

Topic: Arduino Create - Getting Started issues (Read 2176 times) previous topic - next topic


Jun 18, 2019, 12:04 pm Last Edit: Jun 18, 2019, 01:08 pm by markantonyporter Reason: Correct typos
Hi All,

I'm looking for some help, yesterday my new Arduino MKR WiFi 1010 arrived and the fist thing I did was to update the firmware as per instructions.  All went well & this was updated correctly & confirmed using the CheckFirmwareVersion sketch from within the Arduino IDE - Everything passed ok.

Firmware version installed: 1.2.1

Check result: Passed.

I then successfully updated the certificates as per instructions.

Next I proceeded to move onto move onto Arduino Create's - Getting started set-up steps.  

I successfully followed the steps:

1. Connected via USB.
2. Named my board.
3. Configured the board.
4. Uploaded the sketch.  

However when I come to the 'Connect to Cloud', the board repeatedly fails & I get the message: 'We couldn't connect to the Arduino Cloud' & appear to be unable to get past this next step.

Suspecting the board might have connection issues I went back into the Arduino IDE and tested its connection with several example sketches from WiFiNINA.  Which all appear to work as expected, as you can see from the attached pictures; with the WiFiPing sketch my board was able to connect to the internet & successfully ping Google's server - So I know my board is able to connect to my WiFi.

For the record I'm using a Windows 10 PC (64 Bit), updated to version 1903. Google Chrome Version 75.0.3770.90 (Official Build) (64-bit).  I'm unfortunately also using McAfee Anti Virus and have excluded the Arduino_Create_Bridge.exe from Real-Time Scanning.  I'm able to use my MKR 1010 with the Arduino Web Editor successfully and send the blink sketch across without issue; so I know the bridge is working correctly.  From within the McAfee settings I've tried turning off both the Anti-Virus & the Firewall and giving it another go & still nothing.

So my question is: Why when using Arduino Create's getting started process, can I not get my board to connect to the cloud and pass Step 5?

Any suggestions would be gratefully appreciated?

Kind regards,



Hi Mark, sorry to read this.

 There can be various explanation to this issue, but I suggest you to go ahead and create a Thing at https://create.arduino.cc/iot/things/new, skipping step 5 since it's no more than a test/demo, not an essential thing to do in order to complete the configuration.

 Make sure you select your device, then click on CREATE and you should end up in your new Thing's page. Here, I need you to look for the Thing ID: (on top of the page) and for your board's ID: (in the white panel at the bottom of the page).

 Please, paste those strings here (and a screenshot of the page, if in doubt), so that we can look for some useful error message in our logs. You can also try and play with your new Thing, edit the code and upload the sketch. If you do that, let us know if the board succeed to connect to the Cloud that way.

I hope to be helpful,



Jun 18, 2019, 04:35 pm Last Edit: Jun 18, 2019, 04:50 pm by markantonyporter
Hi Alberto,

I followed the 'Thing' tutorial to the letter, it complied and uploaded to the board perfectly.  But I had absolutely zero output in the serial monitor - Then I got to the point within Web Create where I was eventually faced with 'No more compilation time available for today'.  
So not wanting to quit, I downloaded the whole project and opened it up on my desktop Arduino IDE and uploaded it to my board.  I'm no further forward, at my first attempt the connection did nothing, the 2nd got the following response (see attached pictures).

'Bogus NTP time from API, fallback to UDP method'  

Guess I'll try again tomorrow.




We will check that, but it would really help us if you could paste your Thing ID and your Board ID


Hi Alberto,

Details as requested.

***** Arduino IoT Cloud - configuration info *****

Device ID: e845a480-f9b4-44b2-b490-caac9317c575
Thing ID: 28ef7a9a-23be-4477-aa0a-632343799bc9
MQTT Broker: mqtts-sa.iot.arduino.cc:8883
WiFi.status(): 0
Current WiFi Firmware: 1.2.1
Connecting to "VM075456-2G"
Connected to "VM075456-2G"
Connecting to Arduino IoT Cloud...
Bogus NTP time from API, fallback to UDP method
Bogus NTP time from API, fallback to UDP method

Many thanks,



hi @markantonyporter

an error in retrieving time from the NTP server is more common than you think, but usually after 2-3 attempts it goes well and the connection moves forward to negotiating over TLS (time is key for this step).

would you mind reporting what's the debug level set at?
it's a line in your setup()
Code: [Select]


I'd invite you to set it 4 for maximum verbosity and paste the output after it's been running for a bit.
Hopefully we can help you get around this.
Of course if your provider blocks NTP calls there's very little we can do right now, if not consider that this might be a possibility (you'd be the first to report such a case) and set a further alternative up :)

we're at the end of the day in Europe, but either Alberto or I will get back to you as soon as we're back at work.



Hello, another thing you could try is to connect to a different network, or maybe the hotspot from your phone.
You have something connected to your arduino? Such as sensors or other things..

Let us know


Jun 19, 2019, 01:50 pm Last Edit: Jun 19, 2019, 03:52 pm by markantonyporter
Hi All,

Okay firstly a big thank you EVERYONE, I finally got it working (YAY).  I tried Umberto's suggestion of using a hotspot from my phone, it connected first time.  

I spent a few minutes on Google & it would appear the issue is with my router & Virgin Media UK blocking NTP calls, I'm off to discuss this with them shortly and will let you know the outcome.

Once again thank you all for your assistance.

Kind regards,



Jun 19, 2019, 03:25 pm Last Edit: Jun 19, 2019, 03:26 pm by markantonyporter
Well my call to Virgin Media's tech support was enlightening, as the guy asked me what a micro-controller was? (I kind of lost all hope at this point).  

The thing that annoyed me the most was they want to charge me  a £5 per month "Tech Support" subscription (for a service I'll only use once), or for a one off charge of £60 before looking at it.  

Needless to say I terminated the telephone call out of pure frustration, only wish I could terminate my contract with them so easily and switch providers!

The mobile hotspot, whilst it works, is far from an ideal solution - As my board is in a fixed location & I'm not LOL.

Strangely I have no such issues with 3 x Adafruit Huzzah Feather's, which are all connected to Adafruit IO (all works flawlessly on the very same router).

Time to start digging deeper, when I can find the time.


hi Mark Antony

it is our pleasure to try and help resolving our users' issues :)
I know very well how frustrating it can be when the customer support "technician" is of no help as soon as you come up with the right questions.
In this case we're very happy you are a knowledgeable user who's able to troubleshoot proactively, it makes our job easier :)

So... my worst case scenario (NTP calls block) seemed to be the culprit... that is unfortunate.
I understand you having no issue connecting to Adafruit IO. If I remember well their system only employs username:password login and their boards do not sport a cryptography (ECC) chip.
We started IoT Cloud by leveraging our cryptography hardware and pre-provisioning our boards with generated certificates to allow the board to negotiate a connection by not using credentials which would otherwise be part of the source code (network login credentials are still in your firmware, of course).

If it can help we're working actively on implementing such a system for 3rd party hardware, but it's nonetheless a bummer having such capability on your board and not being able to use it at its best.

In the meantime I've looked into the possibility to force time requests through the hardware module (it now falls-back on the NTP call at first failure to save time) but the modules employ similar workflows and would most likely be blocked by your provider anyway.

Please be patient, we've been working behind the scenes to allow more ways to connect to IoT Cloud, and in your specific case a username:password authentication scheme might be a solution.

Should you have more questions or doubts just keep using this thread, we'll be more than happy to support you :)


Go Up