Go Down

Topic: Using the On-board BLE (Read 1 time) previous topic - next topic

TkwAnderson

Oct 04, 2018, 09:11 am Last Edit: Oct 04, 2018, 09:22 am by TkwAnderson
Good Morning,
what library do we need in order to use the on-board BLE?
Cheers

sandeepmistry

Hi @TkwAnderson,

At the moment there is no Bluetooth support on the firmware running on the NINA module, therefore there is no library to do this currently.

TkwAnderson

Thanks, that would explain why I can't find anything.
Has there been any indication when the on-board BLE will be available?
Cheers

exeless

Hello everyone,
+1 on this question.

Is the BLE support planned in the next 2-3 months?

jwestmoreland

Hello All,

I will just throw this out there - but with the latest ESPtools you should be able to enable BLE(test only).

Please note, though - you'd have to also make the appropriate libs to make use of it.  Maybe not if the data xmission code has been abstracted enough...

For an electrical test though - just to see if your iPhoid could see/possible pair - that much should be possible with making a build now.

I may post a test build for this later...

Regards,
John W.

DarioPennisi

Hi,
we currently have a firmware that enables BT but that has not been ported to vidor yet as we need to fix some communication issues through the FPGA first. i can't commit on a time frame right now as there are some higher priority topics we're working on right now for vidor but this is for sure coming.

kuzemchik

Hi,
we currently have a firmware that enables BT but that has not been ported to vidor yet as we need to fix some communication issues through the FPGA first. i can't commit on a time frame right now as there are some higher priority topics we're working on right now for vidor but this is for sure coming.
Any update on this?

angellxp


jomoengineer

I am interested in this as well, however for BLE Support, it is my understanding that this requires at a minimum FW version 1.2.1.  Currently it appears only FW version 1.1.0 is available for the MKR Vidor 4000 so no BLE support at this time.
https://forum.arduino.cc/index.php?topic=579306.0

This could be tracked on the Github locations to see if anything changes though.
https://github.com/arduino-libraries/ArduinoBLE

https://github.com/arduino/nina-fw

I would be nice to see the support though.

Go Up