Go Down

Topic: Having trouble install driver for Google ADK demo board on WinXP (Read 2207 times) previous topic - next topic


May 28, 2011, 04:46 am Last Edit: May 28, 2011, 04:47 am by ashura Reason: 1

I am trying to install driver for the Google ADK demo board that I got from Google IO. When I connect the device to my computer (Windows XP professional), my computer can see a "FT232R USB UART" device. But I stuck at this step - I cannot use the Found New Hardware Wizard, even if I installed arduino software(0022) and have the Arduino MEGA 2560.inf under the drivers folder.

From Google's site(http://developer.android.com/guide/topics/usb/adk.html), it does not say how to install the driver. But it suggests that the device is a Arduino Mega 2560.

So, I tried to follow the instructions on arduino's site(http://arduino.cc/en/Guide/Windows), I stuck at step 4. My computer's device manager cannot see anything on COM1.

Anyone has experience on installing the driver for this board? Thanks in advance!


See if this helps.......



Thanks for the tip. My "RunOnce" regkey is in the Reg table. But I deleted it and created it again.

This time windows xp recognized the device as "USB Serial port", and I can install the driver! 

But here comes the new problem, the "Hardware Update Wizard" now says "Cannot Start this Hardware" --- "this device cannot start. [Code 10].

Not sure what I should do. I have tried to uninstall and install the driver a couple of times, and also pressed the reset button on the board. So far, no luck. I will keep trying.


I got it figured out. The right driver for Google ADK demo board should be [arduino folder]\drivers\FTDI USB Drivers\FTDIBUS.INF. Not the one under the drivers folder (Arduino MEGA 2560.inf).

After installing the FTDIBUS.INF, the board works great on my Win XP.

Go Up