Go Down

Topic: MKR1400 We couldn't connect to the GSM network. (Read 1 time) previous topic - next topic

Sakthivel-sr

Hi,

I'm facing an issue in connecting the MKR1400 to the cellular with Arduino SIM in Bahrain. I have entered the APN as viva.bh and username: VIVAGRPS ( no PIN and no password).

Please guide me to establish the communication.

Arduino SIM details.
APN : prepay.pelion
Username :arduino
Password :arduino
Default PIN :0000

Regards,
SR

MatrixLinks

#1
Jul 31, 2019, 04:49 am Last Edit: Jul 31, 2019, 04:51 am by MatrixLinks
I am having a similar issue with MKR1400: can't connect to GSM network in Canada using APN=prepay.pelion, PIN=0000, user=arduino, password= arduino

MatrixLinks

Attempts to connect to GSM network in Canada continue to be unsuccessful.  Ultimately, get error message: "SIM not present or wrong PIN".  The SIM is in place: anybody know if there is a PIN other than 0000 we should be using?

Thanks

gvarisco

Hi MatrixLinks and Sakthivel-sr, could you please open tickets to our Support Team? Please email <support@arduino.cc>

MatrixLinks

Thanks: did send an email to support@arduino.cc but no response yet.

RELTD

Same issue here, anyone had a reply from support yet?

Can establish connection with my own sketch, sending TCP data to server. Can't connect to IoT though.

Tried two different SIMs (that work sending data via TCP) with both the IoT configuration wizzard and uploading an example IoT sketch.

Code: [Select]
/*
  Sketch generated by the Arduino IoT Cloud Thing "LED"
  https://create.arduino.cc/cloud/things/1e8c45b0-af74-4a62-8a0d-82492683e169

  Arduino IoT Cloud Properties description

  The following variables are automatically generated and updated when changes are made to the Thing properties

  bool ledSwitch;

  Properties which are marked as READ/WRITE in the Cloud Thing will also have functions
  which are called when their values are changed from the Dashboard.
  These functions are generated with the Thing and added at the end of this sketch.
*/

#include "thingProperties.h"

void setup() {
  // Initialize serial and wait for port to open:
  Serial.begin(9600);
  // This delay gives the chance to wait for a Serial Monitor without blocking if none is found
  delay(1500);

  // Defined in thingProperties.h
  initProperties();

  // Connect to Arduino IoT Cloud
  ArduinoCloud.begin(ArduinoIoTPreferredConnection);
  ledSwitch = false;
 
  /*
     The following function allows you to obtain more information
     related to the state of network and IoT Cloud connection and errors
     the higher number the more granular information you'll get.
     The default is 0 (only errors).
     Maximum is 4
 */
  setDebugMessageLevel(2);
  ArduinoCloud.printDebugInfo();
}

void loop() {
  ArduinoCloud.update();
 
}


void onLedSwitchChange() {
  digitalWrite(LED_BUILTIN,ledSwitch);
}




The former just returns a failed connection attempt, the latter returns this in the serial monitor with nothing else happening:

[ 13051 ] SIM card ok
[ 13051 ] Connecting to Cellular Network
[ 17179 ] GPRS.attachGPRS(): 4
[ 17179 ] Sending PING to outer space...
[ 17886 ] GSM.ping(): 81
[ 17886 ] Connected to GPRS Network
[ 17889 ] Connecting to Arduino IoT Cloud...

RELTD

#6
Aug 12, 2019, 09:36 am Last Edit: Aug 12, 2019, 09:59 am by RELTD
Update from my end, tried again this morning and get same output in the serial monitor as previous post, but now continues on to print:

"Bogus NTP time from API, fallback to UDP method"

edit:

Setting debug print level to 4 returns:

[ 17585 ] SIM card ok
[ 17585 ] Connecting to Cellular Network
[ 21414 ] GPRS.attachGPRS(): 4
[ 21414 ] Sending PING to outer space...
[ 22230 ] GSM.ping(): 87
[ 22231 ] Connected to GPRS Network
[ 22234 ] Connecting to Arduino IoT Cloud...
[ 23150 ] Bogus NTP time from API, fallback to UDP method
[ 25790 ] ArduinoCloud.connect(): 0
[ 26592 ] Bogus NTP time from API, fallback to UDP method
[ 29247 ] ArduinoCloud.connect(): 0
[ 30049 ] Bogus NTP time from API, fallback to UDP method
[ 32665 ] ArduinoCloud.connect(): 0
[ 32687 ] GPRS.isAccessAlive(): 1
[ 32687 ] Connected to Cellular Network
[ 33467 ] Bogus NTP time from API, fallback to UDP method
[ 36045 ] ArduinoCloud.connect(): 0
[ 36847 ] Bogus NTP time from API, fallback to UDP method
[ 39434 ] ArduinoCloud.connect(): 0
[ 40237 ] Bogus NTP time from API, fallback to UDP method
[ 42849 ] ArduinoCloud.connect(): 0
[ 42871 ] GPRS.isAccessAlive(): 1
[ 42871 ] Connected to Cellular Network

RELTD

Arduino support had informed me IoT only works with Arduino SIMs.

Purchased and received my Arduino SIM today. Same Serial Monitor output as above as a result.

Go Up