Go Down

Topic: [Solved] Problems while setting fuses but nothing else (Read 377 times) previous topic - next topic

LxO

Long time lurker first time poster :P

I'm trying to disable the reset pin on an attiny 25 by setting the fuses.

I'm using a arduino mega2560 and avrdude to do this.

However, each time I try to set the fuses I get the ever helpfull error message:

Quote
avrdude: stk500_getsync(): not in sync: resp=0xe0

avrdude done.  Thank you.
I can program/burn a bootloader without issues.

I've tried both the "old" pin out and the new one for the programmer (both work to program with).

I've tried with or without the filter capacitor on the programmer.

and the command im using to set the fuses is:
Quote
avrdude -c stk500v1 -p t25 -P com7 -v -v -U lfuse:w:0x62:m -U hfuse:w:0x5f:m -U efuse:w:0xff:m
Am I doing something wrong or is this maybe just not possible with my setup?

pert


LxO

That worked!

I saw the baudrate option in the documentation but couldn't remember setting it in the arduino IDE.


Now Im getting flashbacks to my first Arduino experience trying to program a Megatronics V2 (Mega 2560 based) board for 3D printing

pert

You don't need to set the baudrate in the Arduino IDE. It's defined in the Arduino as ISP programmer definition:
https://github.com/arduino/ArduinoCore-avr/blob/1.6.23/programmers.txt#L44-L51
Code: [Select]
arduinoasisp.name=Arduino as ISP
arduinoasisp.communication=serial
arduinoasisp.protocol=arduino
arduinoasisp.speed=19200
arduinoasisp.program.protocol=arduino
arduinoasisp.program.speed=19200
arduinoasisp.program.tool=avrdude
arduinoasisp.program.extra_params=-P{serial.port} -b{program.speed}

Go Up