Go Down

Topic: Due board not recognized by IDE (Read 341 times) previous topic - next topic

malgosia

I have a Due connected to an Ubuntu 18.04 system, and I am using version 1.8.9.  of the Arduino IDE. I used the Board Manager to install the Due-specific libraries.  The Ports interface on the IDE recognizes the two USB ports that the Due is using, and recognizes one of the as the Programming Port.  But the IDE's "Boards" tool does not list any of the Due interfaces.  After I unsuccessfully attempted to install the Blink sketch on the Due, the "Get Board Info" tool gives me the correct info about the board (i.e. recognizes the Due Programming Port), but the "Boards" menu continues to not give me any Due-related options.  I already tried uninstalling/reinstalling the IDE, etc.  What can I do to fix my problem?  All help will be tremendously appreciated!

pert

I used the Board Manager to install the Due-specific libraries.
Do you mean that you installed the hardware core listed as: "Arduino SAM Boards (32-bits ARM Cortex-M3) by Arduino"?

malgosia

Do you mean that you installed the hardware core listed as: "Arduino SAM Boards (32-bits ARM Cortex-M3) by Arduino"?
Yes, exactly.

pert

That is very strange. It shouldn't be necessary, but try closing all the Arduino IDE windows you have open and then restart the Arduino IDE to see if the Tools > Board > Arduino Due board options appear.

Note that the Due boards are listed under the AVR boards (e.g., Uno, Mega, Leonardo) on the Tools > Board menu. You might need scroll the menu downwards to see the Due boards. You can do that by hovering your mouse pointer over the downward pointing triangle at the bottom of the menu.

malgosia

That is very strange. It shouldn't be necessary, but try closing all the Arduino IDE windows you have open and then restart the Arduino IDE to see if the Tools > Board > Arduino Due board options appear.
I tried this more than once, but without success.  Finally, I noticed that the Arduino preferences.txt file contains a "board=" entry, so I copied this entry from another Ubuntu computer which I had previously successfully gotten to work with my Due (what luck!).  This solved my problem, although the solution is not entirely heart-warming...

Go Up