Go Down

Topic: Ultrasonic ping))) not working properly (Read 95 times) previous topic - next topic

Toysbox

Hello,

I purchased a parallax ultrasonic ping))) a bit ago and once I got it I made sure it worked with the Examples>06.Sensors>Ping program and the sensor worked just fine. I had to shelf the sensor for a bout a week waiting on more parts. I pulled my sensor back down and tried to test it out again but this time its only giving a constant pulseIn of 18289, which is 315cm.
I have tried unplugging and re-plugging all the wires and the connection several times but the output never changed.
I did find a post on these forums for a new library for distance sensors, NewPing Library. (https://forum.arduino.cc/index.php?topic=106043.0) I downloaded the library and tried out the examples sketch. Since I am using a three pronged sensor I made the echo and trigger pin the same pin of 9, the pin I used. Now the sensor is constantly outputting a slightly larger value of 18395, 322cm.

I am also using an external battery of four AA batteries that should give a 5V supply to my system. I tried using the voltage source from the arduino but that did not change anything.

I would like to know if somehow I broke the sensor or there are any other troubleshooting techniques I can try to get my sensor to work again.
Thank you.

Go Up