Go Down

Topic: Library meant for an Arduino or Nucleo board? Then, error: NODE_F207ZG not found (Read 89 times) previous topic - next topic

Maybe this isn't a programming question: is this library meant for a Nucleo board?
I have a Nucleo-F767ZI. I'm using the Arduino IDE because it's what I know and the STMcube IDE is confusing af.

This is the error:
Code: [Select]
Arduino: 1.8.9 (Windows 7), Board: "Nucleo-144, Nucleo F207ZG, Mass Storage, Enabled (generic 'Serial'), None, Low/Full Speed, Smallest (-Os default), Newlib Nano (default)"

A subdirectory or file sketch already exists.

Sketch uses 34916 bytes (3%) of program storage space. Maximum is 1048576 bytes.
Global variables use 1348 bytes (1%) of dynamic memory, leaving 129724 bytes for local variables. Maximum is 131072 bytes.
NODE_F207ZG not found. Please ensure the device is correctly connected.
An error occurred while uploading the sketch

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.


I tried downloading these:
  • STM32CubeExpansion-SPN2_V1.1.0 package
  • stsw-link007
  • stsw-link008
  • stsw-link009

The executable for the (link009) fails to install the USB driver.   


I just needed to select the right "Board part number" in the Tools Menu.

Problem solved.

Go Up