Go Down

Topic: Conception d'un nichoir connecté ! soucis de LED IR modulé ! (Read 5312 times) previous topic - next topic

dbrion06

Oui
Et la sensibilité au bruit serait un peu moindre (mais vous consommez un peu plus). avec analogwrite(D3,200), vous avez des impulsions hautes le 1/5 ième du temps)

al1fch

Quote
essayer le code de @al1fch du post 97 : essayé ce matin : sans résultat probants
dans ce message #97 le code proposé produit un signal carré de fréquence 38kHz
Ci dessous le courant dans une DEL dont l'anode est branchée à la sortie D3, la cathode branche à une résistance dont l'autre extrémité  est reliée à  D2

Salve d'environ 0,5ms, carré 38kHz


Je n'affirme pas  que c'est LA solution , il serait plus pratique de travailler en émission continue mais comme la question de la production de salve a été  soulevée je montre que, juste qu'avec AnalogWrite et Servo, sans boucle de code,  on peut produire facilement  des salves de signaux carrés à 38kHz (dans les limites des possibilités de Servo, salves de 0,5 ms à 2,5ms)

rer67

Ce soir j'ai essayé ma barrière ir avec un morceau de gaine thermorétractable de 4cm à l'avant de la led .pour simuler le soleil j'ai pris un phare à incandescence. Avec le tube c'est largement mieux ! Faudrait que je vérifie avec des conditions de soleil réel !. En tout cas merci du tuyau JML.
Je pense que le ky-032 est également une bonne solution en deportant la led....
A voir

rer67

Hello.
Après quelques essais, un petit retour d'expérience :
J'ai reçu mes photodiode Tssp4038 et les del tsal6200. Ce couple fonctionne très bien en branchant la del sur la sortie à 38khz de la node mcu. Donc effectivement pas besoin de train d'impulsions.
Après plusieurs essais à la lampe tungstène, un tout petit bout de tube de 1 cm suffit à inhiber les interférences lié aux UV. Reste à tester en extérieur....
Mai une chose me turlupine... J'ai fait les tests avec une résistance de 100 et 38 ohm avec la led branché sur ma node donc à 38khz. Mais comme je mesure la tension au voltmètre je n'ai pas de valeur correcte.... Quel est la valeur de la résistance que je doit utiliser avec ma del branché sur le 3.3v de ma node en 38khz..... Si elle n'était pas sur du 38khz je dirait  30 ohm pour 1.3v et 60ma  la datasheet est la
http://www.farnell.com/datasheets/2049868.pdf.
Comment alimenter ma led ir de 70 (on va dire 100ma) avec ma node mcu ?  L'essai à fonctionné mais j'ai l'impression que la led était plus que très faiblement alimentée...  Avec un transistor 2n222 ? Faut il y mettre une résistance ?

Merci de votre aide !

al1fch

Bonsoir
Quote
J'ai reçu mes photodiode Tssp4038 et les del tsal6200. Ce couple fonctionne très bien en branchant la del sur la sortie à 38khz de la node mcu. Donc effectivement pas besoin de train d'impulsions.
Bonne nouvelle, cela confirme ce que la notice technique des TSSP4038 laissait entrevoir
Merci pour la confirmation. La gestion de la barrière IR à 38kHz reste donc simple a mettre en oeuvre avec un ESP8266 et AnalogWrite()

Pour le courant , si la largeur de la barrière IR de nichoir le permet,  le plus simple serait de rester à une commande par sortie GPIO, en se contentant des 12mA que peut fournir une sortie GPIO d'un ESP8266.
Pourquoi pousser à 100mA le courant dans la DEL Infra Rouge, dans le cas du nichoir ?

S'il est nécessaire de fournir plus que 12mA,  ajouter un transistor bipolaire ou moset et une résistance pour maîtriser le courant dans la DEL à la valeur nécessaire à la largeur de la barrière

(Avec une tension  et un courant carrés  tenir compete du fait que la valeur moyenne est la moitié de la valeur crête)

rer67

Salut,
oui tu as raison je vais essayer avec 12ma cela simplifierais grandement le montage , et en plus je n'ai pas beaucoup de place !!!
donc pour 12-15ma environ j'aurai 1.2v a la del et donc il me faut une résistance de 140 à 160 ohm c'est cela ? ou une autre valeur ?

MErci

al1fch

Bonjour

Une sortie GPIO (ESP8266) fournissant 12mA donnera  une tension un peu plus faible que 3,3V, je tenterai 100 Ohm .
Si l'intensité lumineuse s'avère insuffisante il l est possible , toujours en sortie directe de GPIO, de mettre deux DEL en série et abaisser la résistance  à 50 Ohm ou plus.


J-M-L

il l est possible , toujours en sortie directe de GPIO, de mettre deux DEL en série et abaisser la résistance  à 50 Ohm ou plus.
si une des deux flanche et devient passante (je ne sais pas si ça peut arriver) l'appel de courant sur la PIN deviendra important, non ?
Hello - Please do not PM me for help,  others will benefit as well if you post your question publicly on the forums.
Bonjour Pas de messages privés SVP, postez dans le forum directement pour que ça profite à tous

al1fch

D'accord !
Il me semble toutejois que la court-circuit n'est pas le mode de défaillance le plus fréquent pour les DEL.
La mise en série de DEL IR se rencontre dans des télécommandes "de marque"

J-M-L

OK - oui j'imagine que si elle flanche, elle devient plutôt un interrupteur ouvert
Hello - Please do not PM me for help,  others will benefit as well if you post your question publicly on the forums.
Bonjour Pas de messages privés SVP, postez dans le forum directement pour que ça profite à tous

al1fch

D'autre part une éventuelle défaillance en court-circuit de la DEL unique donne également une sur-intensité pour le GPIO

rer67

il l est possible , toujours en sortie directe de GPIO, de mettre deux DEL en série et abaisser la résistance  à 50 Ohm ou plus.


Re,

cela est intéressant car si l'intensité lumineuse est suffisante avec une DEL par barrière, je pourrais tout de même en mettre 2 en série : l'une pour la barrière extérieure et l'autre pour la barrière intérieure ... ( ca simplifierais le cablage. )
A ce moment là et avec une résistance complémentaire de 50 ohm en série, dans quelle plage de fonctionnement de la DEL je me situerais ? ( 1.2V - 20mA par DEL ? )
on est dans ce cas ? :
[/img]

al1fch

image jointe au message précédent :

ça me parait bon

rer67

alorsss....

si je met 100ohms en resistance j'ai 1.2v et 18ma si je branche le tout sur le 3.3v de la board.
si je met la LED sur le 38KHZ avec les 100 ohms j'ai 0.42v a la led  ??

es-ce normal ?

je n'ai pas d'oscilloscope !

kamill

Oui, c'est normal. La tension 'efficace' dépend du rapport cyclique de la modulation.

Go Up