Go Down

Topic: Problema con Circuito Sim800l, Arduino Nano (Read 372 times) previous topic - next topic

DarkAvenger

Aug 09, 2019, 11:14 pm Last Edit: Aug 10, 2019, 09:26 pm by surbyte Reason: Visualicación de imágenes
Estimada comunidad, estoy haciendo un proyecto con una SIM800L un Arduino Nano y un sensor de presión. La idea del proyecto es recibir los datos del sensor de presión y enviarlos mediante GPRS a una pagina web cada 10 minutos. Con respecto a la programación esta está bien, funciona, pero estoy teniendo inconvenientes con el hardware, tengo conectado todo el sistema a una batería de litio de 3.7 volt, la cual alimenta directamente a la SIM800 y a un regulador de voltaje Step Up que me eleva de 3.7 a 5 Volt para alimentar al Arduino y al sensor. El sistema funciona bien la primera vez que se carga el sketch al Arduino y se conecta al sistema, éste reporta bien y todo hasta cuando la batería se descarga, pero cuando desconecto el Arduino y lo conecto al computador esté no me lo reconoce, cargo la pila nuevamente, hago andar el sistema y no funciona más. Me ha pasado ya dos veces, entonces  no sé que estoy conectando mal, porque se me quema tanto el Arduino como la SIM   :'( . Por favor si alguien me podría ayudar se lo agradecería bastante. Voy a adjuntar un diagrama con el conexionado del proyecto.


tauro0221

Hi,
Todo esta bien hasta que no dices como carga la bateria. El Sim8001 necesita un suplidor de enegia que sea suficiente para suplir un corriente minima de 2 ampeirios. De lo contrario el sim se va a "Shut Down.
Como carga la bateria?

DarkAvenger

Estimado, la SIM800L la estoy alimentando directamente con la pila de 3.7 Volt, entiendo que la SIM se vaya a shut down cuando la tensión no es la indicada, pero mi inconveniente es que cuando vuelvo a montar el circuito una vez cargada la bateria, éste ya no funciona.. por lo que asumo que algo estoy haciendo mal porque se me queman los componentes.. Para alimentar el arduino estoy usando un modulo regulador de voltaje Step Up, basado en el chip XL6900

tauro0221

Hi,
Ahora aqui yo veo  pero no estoy seguro es que estas alimentando el regulador que alimenta el Sim usando l los 5 voltios del arduino. Si es asi entonces vaz a tener problemas pues el regulador del arduino solamente tiena una salida de 800ma. Esto no es suficiente para alimentar todo el systema. Recuerda que el Sim necesita una corriente minima de 2 amperios y el arduino no te va proveer esa corrinte. Aqui lo mejor seria es que consigas una fuente que te provee 5 voltios 3 amperios. Alimentas el arduino con los 5 voltios y a la vez el regulador de 5 a 3.7 voltios.Creo que por eso se estan quemandolos componetes. Pregunta tu alimentas el arduino por Vin o por el USB.

DarkAvenger

Eso mismo estoy haciendo, mira, tengo una bateria de 3,7 volt para alimentar todo el sistema, paralelo a la bateria tengo conectada la SIM800l y el regulador de voltaje que recibe los 3,7 volt y los eleva a 5 para alimentar el Arduino. Claramente todos los componentes están conectados a tierra. Pero no entiendo el porque se quema el sistema cuando lo dejo operando por mucho tiempo.

tauro0221

Hi,
Ahora como los estas explicando entiendo como esta alambrado. Creia que el arduino suplia el regulador pero es al reves. Cuando tu dices que se queman los componentes al cual de ellos te refieres. Todos se queman o es el Sim.Aqui creo que vaz a tener que leer los voltajes para ver que es lo que esta pasando. Para que se quemen tiene que a ver un voltaje bien alto y la bateria no puede hacerlo.El unico suspechoso seria el regulador. Aclara cual de los componentes se queman para tener una idea. Para mi la prueba para determinar el problema es las lecturas de los voltajes.

Busque las especificaciones de regulador y dice que el voltaje de entrada es de 5 voltios a 32 voltios. Quire decir que no puedes usar la bateria para alimentar el regulador. Sin embargo los venden diciendo que la entrada es de 3.3 a 32 voltios y no es cierto.

AlexLPD

Lo mas seguro es que el regulador este chico para la aplicación, y los arranques o envios de datos del modulo, que son picos de 2.0A, lo esten calentando hasta que terminen por dañarlo.

Una prueba sencilla, seria poner dos step up, uno para el arduino y otro para el mudulo, logicamente se va a quemar el del modulo y con eso puedes darte   a  la tarea de conseguir uno mas grande.
Ojo que la corriente Maxima que vienen indicada no es adecuada para trabajo continuo. Pero eso tendrías que verlo en tu hoja de datos.

Saludos.
-Alex.

Go Up