Go Down

Topic: Interference between end-switch and steppermotor (Read 134 times) previous topic - next topic

SimonVanDenBerg

Hi everyone,

I have an Arduino with a Nema 23 3A stepper motor and an end switch attached to the Arduino with a 1K pull-up resistor. I tested the end switch and it works fine without having the stepper motor enabled. But when i power the stepper motor, the cables to the motor interfere with the cables to the endswitch. So the Arduino thinks the endswitch is pressed while it's not. How is this possible? I thought a pull-up resistor was meant to prevent interference? I tried a lot with different internal and external pull-up and pull-down resistors. but nothing seems to solve the problem. Can somebody help me pls?

Kind regards,

Simon van den Berg

Paul_KD7HB

Hi everyone,

I have an Arduino with a Nema 23 3A stepper motor and an end switch attached to the Arduino with a 1K pull-up resistor. I tested the end switch and it works fine without having the stepper motor enabled. But when i power the stepper motor, the cables to the motor interfere with the cables to the endswitch. So the Arduino thinks the endswitch is pressed while it's not. How is this possible? I thought a pull-up resistor was meant to prevent interference? I tried a lot with different internal and external pull-up and pull-down resistors. but nothing seems to solve the problem. Can somebody help me pls?

Kind regards,

Simon van den Berg
Schematic of your project is necessary to offer any help.

Paul

Slumpert

If you omit your resistor and switch, are you going from
Arduino port pin to Ground pin (best method) or 5v pin to Arduino port pin?

Go Up