Go Down

Topic: Problem with an Arduino Uno as ISP trying to upload sketch on ATtiny85 (Read 816 times) previous topic - next topic

diamant711

Hi, i have some ATtiny85 that i want program with the Arduino Uno…
I have done this step:
  • I add the URL:"https://raw.githubusercontent.com/damellis/attiny/ide-1.6.x-boards-manager/package_damellis_attiny_index.json" to the Additional Board Managers URLs
  • I download Attiny by David. A Mellis in the board manager (i have tried with the ATTinyCore too)
  • I upload the sketch "Arduino as ISP" on the Arduino Uno
  • Now i have written this simple sketch to blink a led
  • And i have done the connection between the Arduino Uno and the ATtiny
  • In the end when i'm trying to upload the sketch (blink) i recive this error:

Quote
avrdude: Version 6.3-20171130
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch
         System wide configuration file is "D:\Programmi\Arduino\hardware\tools\avr/etc/avrdude.conf"
         Using Port                    : COM4
         Using Programmer              : arduino
         Overriding Baud Rate          : 19200
         AVR Part                      : ATtiny85
         Chip Erase delay              : 400000 us
         PAGEL                         : P00
         BS2                           : P00
         RESET disposition             : possible i/o
         RETRY pulse                   : SCK
         serial program mode           : yes
         parallel program mode         : yes
         Timeout                       : 200
         StabDelay                     : 100
         CmdexeDelay                   : 25
         SyncLoops                     : 32
         ByteDelay                     : 0
         PollIndex                     : 3
         PollValue                     : 0x53
         Memory Detail                 :
                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           eeprom        65    12     4    0 no        512    4      0  4000  4500 0xff 0xff
           flash         65     6    32    0 yes      8192   64    128 30000 30000 0xff 0xff
           signature      0     0     0    0 no          3    0      0     0     0 0x00 0x00
           lock           0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
           lfuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
           hfuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
           efuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
           calibration    0     0     0    0 no          1    0      0     0     0 0x00 0x00
         Programmer Type : Arduino
         Description     : Arduino
         Hardware Version: 2
         Firmware Version: 1.18
         Topcard         : Unknown
         Vtarget         : 0.0 V
         Varef           : 0.0 V
         Oscillator      : Off
         SCK period      : 0.1 us
avrdude: AVR device initialized and ready to accept instructions
Errore durante il caricamento dello sketch
Reading | ################################################## | 100% 0.01s
avrdude: Device signature = 0x1e9005 (probably t12)
avrdude: Expected signature for ATtiny85 is 1E 93 0B
         Double check chip, or use -F to override this check.
avrdude done.  Thank you.
Blink sketch:
Code: [Select]
#define pinled 3

void setup() {
  pinMode(pinled, OUTPUT);
}

void loop() {
  digitalWrite(pinled, HIGH);
  delay(500);
  digitalWrite(pinled, LOW);
  delay(500);
}


Arduino Uno - ATtiny connection:
Arduino--ATtiny
5VVCC
GNDGND
132
121
110
10reset




Can someone tell me where i am wrong? thanks

pert

Arduino Uno - ATtiny connection:
Arduino--ATtiny
5VVCC
GNDGND
132
121
110

You also need to make a connection between pin 10 on the Uno and the reset pin on the ATtiny85.

diamant711

Oh i forgot to write this connection... But i had already made, and i had the same problem.

PS: I add this connection to the main post

pert

Are you certain the chip is an ATtiny85 and not an ATtiny12 as the read signature indicates?

diamant711

I think that the component is the ATtiny85...

I attach the pictures of the component, is alright?

pert

Yes, the label on the chip definitely indicates it's an ATtiny85, not an ATtiny12.

diamant711


pert

Does it read the same signature:
Code: [Select]
avrdude: Device signature = 0x1e9005 (probably t12)
every time you upload, or does the signature change?

diamant711

Yesterday i read the comment under the internet page where i bought the ATtiny85 and i relized that a lot of people have the same problem becouse the component Is an ATtiny12 whit the label of ATtiny85... :(

Thank you for all!

pert



BuXTeR

Hi guys,

I'm having the same trouble with chips bought on Ali, I've the same result as Diamant711 with AVRDude.

But one thing alert me on wrong operation I do, because T12 do not have 512b of eeprom size, and not 8K of flash size anymore.

I think we are doing something wrong with our chips.

But the signature is very strange, I've realy the same thing !!!

I give another try with other T85 received today, if it does the same thing, we are wrong with our ISP.

diamant711

Hi,
I could not verify that they are actually ATtiny12 ... keep us updated on the result of the programming of your T85!
:)

BuXTeR

Hi Guys,

I've tried several AT85 from other seller and same result ! So, I check on the different howtos on the net and I understand !

When you burn the ArduinoAsIsp on the Uno, you have to select the MKII programmer.
Next, before uploading the sketch to the AT85, select the Arduino As ISP, select the "8Mhz clock Internal" and select "burn boot sequence"
And now, already in "Arduino as ISP" you can burn your sketch in the AT85 ...

That's all !

Can you try this method ? It works for me, also for the Ali chips !

Kind regards

Go Up