Go Down

Topic: ESP32 + 3.5 TFT IL9486 (SPI - not working, parallel - blue screen) (Read 189 times) previous topic - next topic

NKRT

Hi!

I've tried to conect an ESP32 (https://www.aliexpress.com/item/32928267626.html)

with 3.5 TFT display (IL9486 driver) (https://www.aliexpress.com/item/32609807497.html

using TFT ESPI https://github.com/Bodmer/TFT_eSPI 
in two different ways: SPI and Parallel (once again using examples in TFT espi library)

but all I got is:

SPI - not working at all, blank display
Parallel - Display works but the only color is blue (in different shades) and sometimes Green appears.   

Please help
Thanks in advance!

david_prentice

Your display has 8080-16 parallel interface.
It is designed as a Shield to plug into a MEGA2560 or DUE.

Bodmer's library only supports 8080-8 parallel
ESP32 has not got enough pins for 16-bit parallel.

David.

NKRT

Thanks for your response!
As far as I understand - there is no way of connecting this display to the ESP32.   
Can you please advise me what displays I can use with ESP32? (2.2inch+ with good resolution)
Thank you once again!

david_prentice

There a whole range of Chinese Red SPI displays e.g. 2.8 inch with Touch

I suggest  2.4 inch 240x320 or 3.5 inch 320x480
These are the displays that most people use with ESP8266 or ESP32

David.

NKRT

Thanks!
So If I got you right - I need to chose one of the displays that have ILI9341 Driver like these:   

2.2 https://www.aliexpress.com/item/32607741715.html
2.8 https://www.aliexpress.com/item/32982544355.html
3.2 https://www.aliexpress.com/item/32960934541.html

david_prentice

240x320 is ILI9341
320x480 is ILI9488

Google for "Surenoo"
They have a wide range of displays.

David.


Go Up