Go Down

Topic: IDE won't run or reinstall. (Read 184 times) previous topic - next topic

crchisholm

I used the ARDUINO IDE most of the day before yesterday.  Yesterday, windows 10 forced an update.  Now I can no longer bet into the Arduino IDE.  The spash screen come up for about a half second and goes away.  I tried deleting and reinstalling and get the same thing.   The update also seemed to zap my drobox access. 

Has anybody ran into anything like this?   If so, how did you resolve it.
Charlie R Chisholm

ballscrewbob

Win 10 has caused a few people to suffer in recent months.

Usually a quick fix is to roll back any update that may affect hardware (not just Arduino).

Adding some install / un-install info that has also proved useful in the past.

A little more detail if you can not get going with those two methods may also help.

Bob.

It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

pert

Please do this:
  • Start the Windows command line "cmd".
  • Run the program arduino_debug.exe that you will find in the Arduino IDE installation folder from the command line.
  • Copy the output that's printed to the cmd window and paste it here USING CODE TAGS (</> button on the toolbar).

Hopefully that will give us some information we can use to help you with the problem.

crchisholm

@Pert, I am having trouble finding nthe arduino_debug.exe.  It is not on my computer and I checked this sites d downloads page and didn't find.  Where might I find it?

@ballscrewbob:  If I roll back to prior to the update, won't I be forced to do the update again? 
Charlie R Chisholm

pert

arduino_debug.exe is in the Arduino IDE installation folder, in the same place as arduino.exe. If you are using the Windows App version of the Arduino IDE then Windows might be hiding that folder from you.

ballscrewbob

As far as rolling back an update you can tell windows to HIDE the errant update in future.
That way you wont have to go through that one again.

Here is the MS take on that aspect.

My system is set to AVOID any and ALL NVIDIA updates along with anything related to SKYPE.
Most people just trust MS to have checked things before issuing them. Learned that hard way many years ago to first check online for any issues people may have with a KBxxxxxxx update and then WAIT at least a week and check again before doing them.

Bob.


It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

crchisholm

I've been distracted by other issues, but I did find and run the Arduino_debug utility and it automatically opened the IDE.  Not sure how this is suppose to work, but at least that gives me a way to upload some configuration changes I made to marlin firmware.  Still won't run directly (without going through arduino_debug)

Charlie R Chisholm

pert

That is unexpected. arduino_debug.exe should have the same behavior as arduino.exe, except for outputting some information to the cmd window. What happens if you run the arduino.exe file that is in the same folder as arduino_debug.exe?

Go Up