Go Down

Topic: IDE just killed 3 of my MKR1000 (Read 330 times) previous topic - next topic

dfontaine

Aug 23, 2019, 05:18 pm Last Edit: Aug 23, 2019, 05:19 pm by dfontaine
Hey, so i'm working on this sketch and i've uploaded it 3 times to 3 different arduinos who dies during the upload (it's not a line in my code that does it, i went back to a safe version of my code, one i uploaded and worked multiple times). My MKRs don't show up in device manager when plugged in, double tapping the reset button doesn't fix it, jumping the reset and ground doesn't fix it, holding the reset for 30 seconds and plugging it doesn't work. I've also tried plugging them with a different cable and a different computer.

Here is the upload output

Sketch uses 85612 bytes (32%) of program storage space. Maximum is 262144 bytes.
Atmel SMART device 0x10010005 found
Device       : ATSAMD21G18A
Chip ID      : 10010005
Version      : v2.0 [Arduino:XYZ] Dec 20 2016 15:36:43
Address      : 8192
Pages        : 3968
Page Size    : 64 bytes
Total Size   : 248KB
Planes       : 1
Lock Regions : 16
Locked       : none
Security     : false
Boot Flash   : true
BOD          : true
BOR          : true
Arduino      : FAST_CHIP_ERASE
Arduino      : FAST_MULTI_PAGE_WRITE
Arduino      : CAN_CHECKSUM_MEMORY_BUFFER
Erase flash
done in 0.842 seconds

Write 86356 bytes to flash (1350 pages)

[=                             ] 4% (64/1350 pages)
[==                            ] 9% (128/1350 pages)
[====                          ] 14% (192/1350 pages)
[=====                         ] 18% (256/1350 pages)
[=======                       ] 23% (320/1350 pages)
[========                      ] 28% (384/1350 pages)
[=========                     ] 33% (448/1350 pages)
[===========                   ] 37% (512/1350 pages)
[============                  ] 42% (576/1350 pages)
[==============                ] 47% (640/1350 pages)
[===============               ] 52% (704/1350 pages)
[=================             ] 56% (768/1350 pages)
[==================            ] 61% (832/1350 pages)
[===================           ] 66% (896/1350 pages)
[=====================         ] 71% (960/1350 pages)
[======================        ] 75% (1024/1350 pages)
[========================      ] 80% (1088/1350 pages)
[=========================     ] 85% (1152/1350 pages)
[===========================   ] 90% (1216/1350 pages)
[============================  ] 94% (1280/1350 pages)
[============================= ] 99% (1344/1350 pages)
[==============================] 100% (1350/1350 pages)
done in 0.566 seconds

Verify 86356 bytes of flash with checksum.
Verify successful
done in 0.080 seconds
CPU reset.
Couldn't find a Board on the selected port. Check that you have the correct port selected.  If it is correct, try pressing the board's reset button after initiating the upload.

I'm completely out of ideas and i'm scared to kill another one so i can'r really work.
Anyone knows what the hell is going on?

Go Up