Go Down

Topic: Sketch will nicht auf Nano hochladen (Read 216 times) previous topic - next topic

Yannes

ich bekomm bei hochland immer "

Der Sketch verwendet 1896 Bytes (6%) des Programmspeicherplatzes. Das Maximum sind 30720 Bytes.
Globale Variablen verwenden 184 Bytes (8%) des dynamischen Speichers, 1864 Bytes für lokale Variablen verbleiben. Das Maximum sind 2048 Bytes.
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00
Beim Hochladen des Sketches ist ein Fehler aufgetreten

"und im Monitor kommt ein ASSCI Table, wieso auch immer. Kann wer helfen??

combie

Alle sagen: Das geht nicht!
Einer wusste das nicht und probierte es aus.
Und: Es ging nicht.


Yannes

oder doch nicht....
das kommt beim (old bootloader)

avrdude: stk500_paged_load(): (a) protocol error, expect=0x10, resp=0xe0
avrdude: stk500_cmd(): programmer is out of sync
avr_read(): error reading address 0x0000
 read operation not supported for memory "flash"
avrdude: failed to read all of flash memory, rc=-2
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x00

postmaster-ino

Hi

Ok - dann wird's Zeit, daß Du damit rausrückst, was der Kompiler so Alles anzumeckern hat - Das machst Du in den Einstellungen, wo Du Häkchen für SÄMTLICHE Meldungen beim Kompilieren und Hochladen anzeigen lässt.
Alles, was im oberen Bereich rot ist, ist bäh.

Man kann auf einen Nano auch den Bootloader eines UNO brennen - ist der gleiche µC.
Dann ist dieser Nano allerdinge für die IDE ein Uno.
Woher ist das gute Stück?

Hat das Überspielen bereits funktioniert?
Mit diesem Target?
Funktioniert's mit einem anderen Nano?

MfG
anscheinend ist Es nicht erwünscht, einen Foren-internen Link als 'Homepage' einzubinden, damit JEDER nur einen Klick von combie's Liste zum Thema State-Maschine entfernt ist.
... dann eben nicht ...

Yannes

avrdude: Version 6.3-20171130
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

         Using Port                    : COM3
         Using Programmer              : arduino
         Overriding Baud Rate          : 57600
avrdude: ser_open(): can't open device "\\.\COM3": Das System kann die angegebene Datei nicht finden.



avrdude done.  Thank you.

Problem beim Hochladen auf das Board. Hilfestellung dazu unter http://www.arduino.cc/en/Guide/Troubleshooting#upload.
Das Board an COM3 ist nicht verfügbar


das kam raus und ist mein erster Nano

Yannes

anderes Problem der nano leuchtet nicht mehr. Hab schon rein und raus gesteckt
 

combie

Quote
avrdude: ser_open(): can't open device "\\.\COM3": Das System kann die angegebene Datei nicht finden.
Der Meldung kann man glauben!

Was sagt denn dein Gerätemanager?
Auf welchem seriellen hängt der Nano?


Quote
anderes Problem der nano leuchtet nicht mehr. Hab schon rein und raus gesteckt
Aua.

Anderes Kabel, anderen USB Port, anderen Rechner.
 
Alle sagen: Das geht nicht!
Einer wusste das nicht und probierte es aus.
Und: Es ging nicht.

Yannes

er hing auf com3
anderes kabel, anderer pc und anderer usb port hab ich versucht

combie

#9
Aug 24, 2019, 02:57 pm Last Edit: Aug 24, 2019, 03:00 pm by combie
> er hing auf com3
Das war nicht meine Frage.


> der nano leuchtet nicht mehr.
Und das Problem persistiert....?!?

Tja.....
Ein grausames Schicksal.


Wenn du dir sicher bist, dass du das nicht zerstört hast, dann reklamieren.
Wenn du dir sicher bist, dass du das zerstört hast, dann auf dem Konto "Erfahrung" verbuchen.

Ansonsten:
Fehler suchen und beheben.
Der Schaltplan liegt öffentlich aus.





Alle sagen: Das geht nicht!
Einer wusste das nicht und probierte es aus.
Und: Es ging nicht.

wapjoe

Mal interessehalber, was hast du denn mit dem Nano vorher gemacht? Vielleicht eine Schaltung aufgebaut?
Ich hoffe mein Schaden hat kein Gehirn genommen!

- Homer S.

Yannes

Keine Ahnung . Ich hab jetzt beim uno den 5V pin mit Vim verbunden und schon geht alles. Ich bekoome Serial Output und kann was hochladen. Kill ich damit theoretisch den uno oder nano ?

postmaster-ino

#12
Aug 28, 2019, 09:26 pm Last Edit: Aug 28, 2019, 09:28 pm by postmaster-ino
Hi

Vin ist VOR dem Spannungsregler, 5V DAHINTER.
Spätestens, wenn Du den Buchsenstecker benutzt, stirbt Dir was weg.
An USB angeschlossen hast Du ebenfalls 5V am 5V-Pin - wenn nicht, ist dort ein FET wohl verstorben, Der die 5V von USB zum Arduino weiter leiten soll.
Deshalb ist Es auch keine gute Idee, USB und externe 5V (oder Vin) gleichzeitig zu benutzen, da über den FET auch Strom ZUM Rechner fließen kann.

MfG
anscheinend ist Es nicht erwünscht, einen Foren-internen Link als 'Homepage' einzubinden, damit JEDER nur einen Klick von combie's Liste zum Thema State-Maschine entfernt ist.
... dann eben nicht ...

Tommy56

Keine Ahnung . Ich hab jetzt beim uno den 5V pin mit Vim verbunden und schon geht alles. Ich bekoome Serial Output und kann was hochladen. Kill ich damit theoretisch den uno oder nano ?
vim kenne ich als vi improved, d.h. einen sehr guten Editor.
Den meinst Du aber bestimmt nicht ;)

Gruß Tommy
"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)

wapjoe

vim kenne ich als vi improved, d.h. einen sehr guten Editor.
Den meinst Du aber bestimmt nicht ;)

Gruß Tommy
vim ist mir zu kompliziert, dann lieber nano, womit wir wieder beim Thema wären ;) :D

@TO: Ich kann deine Verkabelung nicht nachvollziehen. Wenn du den Nano mit USB flashst, hast du dann noch eine weitere Spannungsquelle angeschlossen? Poste uns doch mal ein Bild vom Nano und der Verkabelung. Wenn ich das recht in Erinnerung habe wird am Vin externe Spannungsquellen von 7,5V - 12V angeschlossen und an 5V externe geregelte Spannung von 5V. Was du nicht machen darfst ist externe Spannung und USB anzuschließen.

BTW.: Geht es jetzt um einen Nano oder einen Uno? Bisher schreibst du immer über einen Nano und jetzt ist es plötzlich ein Uno.  :smiley-confuse:
Ich hoffe mein Schaden hat kein Gehirn genommen!

- Homer S.

Go Up