Go Down

Topic: Mini MP3 Playe- sound nicht mehr hörbar. (Read 228 times) previous topic - next topic

Amondian

guten Abend.

Ich habe ein kleines Problem mit der soundausgabe des Mini MP3 Players.

Nachdem alles reibungslos lief, was sound Ausgabe und steuerung angeht, (über eine ganze weile) ist der Sound schlagartig "weg".

"weg" ist der sound nicht, aber er ist soooooo leise, dass man ihn nur hört, wenn man das Ohr direkt an den Lautsprecher hält und selbst dann muss man schon hinhören. mit dem Code oder der schaltung selber denke ich nicht dass es zusammenhängt, da alles noch genau so läuft, wie vorgesehen.....nur der sound ist kaum hörbar.

Mit Befehlen den Sound hochsetzen klappt nicht, ebenso wenig wie den sound manuell per IO 2 Pin hochzudrehen. Im Prinzip klappt das, sprich ich kann ihn lauter und leiser machen mit den IO pins aber er ist von grund auf so leise, dass das nichts bringt.

orientiert, bzw 1:1 nachgemacht habe ich übrigens das hier:

https://wiki.dfrobot.com/DFPlayer_Mini_SKU_DFR0299?fbclid=IwAR1ALF7ti1sZBx5p9WBz2CsZ8In3kM2TFsbQO4eH47F10zrGWfrveKVWcgc

Da ich leichte Störgeräusche, wie knacken oder "vibrieren" hatte, habe ich ein wenig mit Widerständen rumprobiert, die aber (ich hab es gemacht als das ganze ding lief, vorher im Off-Modus aber auch)  nichts gebracht haben oder meine Schaltung gestört haben. Sprich das Problem war nicht da als als ich rumprobiert habe, sondern quasi bei Betrieb auf einmal.

Mein Projekt ist der Info halber ein Lichtschert. Das heißt die Soundausgabe beläuft sich auf Sirren,Brummen und diverse starsounds.
Das Problem kam während des normalen Brummen, was das Lichtschwert halt so macht.

Ich suche nun die Ursache und hoffe, dass mir hier jemand helfen kann.

Ich habe 3 Theorien, die die Ursache erklären könnten.
1. Durch das dauernde "brummen" was den Lautsprecher (4Ohm 3W) dazu zwingt echt hart zu vibrieren, ist der einfach platt und kann das alles nur noch auf minimalem level wiedergeben
2. Ich habe durch das Herumprobieren irgendetwas an dem MP3 Modul verändert, was die Lautstärke prinzipiell auf 1% (oder so) des möglichen setzt. (Verstärker kaputt?)
3. Ich habe durch einen Kurzschluss oder so die Dateien bzw SD-karte beschädigt......das schließe ich allerdings aus, da die Dateien auf meinem PC noch genau so laut und ohne probleme laufen


Ich habe schon einiges probiert und gesucht, aber noch keine Lösung gefunden. vielleicht könnt ihr mir da weiterhelfen

Deltaflyer

Ich hatte dieses Verhalten bei ner USA-Polizei Sirene mit Attiny85 und nachgeschaltetem Verstärker, dass der Sound plötzlich leiser wurde und gleich darauf kaum mehr hörbar war.
Erst verdächtigte ich den Verstärker.
Der war aber in Ordnung.
Danach stellte sich raus: Lautsprecher (Spule) durchgebrannt.
Hatte so 4Ohm 2-3W mikro Lautsprecher 20 X 40 mm dran. Die sind recht empfindlich.
Da die Sirene in nem Modellauto drin ist, und ich keinen grösseren Lautsprecher einbauen konnte/durfte, hab ich nen kleinen Widerstand in die zuleitung des Lautsprechers eingebaut.
so 2 - 4 Ohm können da schon helfen. Allerdings sinkt damit die Maximallautstärke etwas.

Vielleicht hilft es auch, wenn du statt nem 4 Ohm einen 8 Ohm Lautsprecher nimmst.

Da ich nicht sehe, was fürn Lautsprecher du da eingebaut hast (wegen felender Bilder/Links zum Lautsprecher) kann ich dir keine genaueren tips geben.

HotSystems

Meine Empfehlung, ohne lange rumprobieren, einfach neue Teile besorgen und damit testen.
Den Verstärker auf dem DFplayer kann man schnell killen, wenn man etwas falsch macht.
Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)

Amondian

Danke für die Antwort. Das bringt mich weiter.
Ich vermute auch, dass es der Lautsprecher ist.

Dieser hier wurde verwendet: https://www.amazon.de/gp/product/B07H7BR5GW/ref=ppx_yo_dt_b_asin_title_o06_s00?ie=UTF8&psc=1

Ich habe jetzt neue Lautsprecher bestellt

https://www.amazon.de/gp/product/B07DVFCJ34/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1

https://www.amazon.de/gp/product/B073TSC7RW/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1

und werde es ausprobieren. das MP3Modul habe ich sicherheitshalber auch noch einmal bestellt.


es muss leider so ein kleiner sein, da er in den Griff passen muss.

HotSystems

Danke für die Antwort. Das bringt mich weiter.
Ich vermute auch, dass es der Lautsprecher ist.

und werde es ausprobieren. das MP3Modul habe ich sicherheitshalber auch noch einmal bestellt.

es muss leider so ein kleiner sein, da er in den Griff passen muss.
Was den Lautsprecher betrifft, hättest du ja auch einen anderen testen können.
Dann wüsstest du, ob der es ist.

Ich habe schon div. MP3-DFPlayer in Projekten verbaut, aber noch nie einen Lautsprecher daran kaputt gemacht. Einen DFPlayer schon.
Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)

Amondian

hätte ich einen anderen gehabt, hätte ich das schon ausprobiert

HotSystems

hätte ich einen anderen gehabt, hätte ich das schon ausprobiert

Ok....hat man sowas nicht rumliegen ? ;)
Naja...ich bastel schon etwas länger, da liegt hier sowas rum.

Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)

Amondian

nicht wenn man erst neu einsteigt und noch keinen fundus hat;)


für meine nächsten Projekte bin ich besser ausgerüstet.

also wahrscheinlich wird es der Lautsprecher sein?
 Was hätte ich denn andernfalls am MP§Modul kaputt gemacht?  Sound und steuerung geht ja, halt nur extreeeeeem leise

HotSystems

nicht wenn man erst neu einsteigt und noch keinen fundus hat;)


für meine nächsten Projekte bin ich besser ausgerüstet.

also wahrscheinlich wird es der Lautsprecher sein?
 Was hätte ich denn andernfalls am MP§Modul kaputt gemacht?  Sound und steuerung geht ja, halt nur extreeeeeem leise

Der Verstärker im Player ist sehr empfindlich gegen fehlerhafte Verbindungen. Auch wenn der Lautsprecher falsch angeschlossen wird.
Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)

Amondian

hättest du da vielleicht einen Tipp, was ich an der schaltung verändern könnte, falls es daran lag und das Modul kaputt ist?

HotSystems

hättest du da vielleicht einen Tipp, was ich an der schaltung verändern könnte, falls es daran lag und das Modul kaputt ist?
Wenn du die Schaltung wie in der Beschreibung aufgebaut hast, brauchst du nichts ändern.
Du musst nur darauf achten, den Lautsprecher richtig anzuschließen.

Der darf nicht gegen GND oder +5V geschaltet werden, dann geht der Verstärker kaputt.
Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)

Amondian

Okay Danke für deine Hilfe

Der Speaker ist lediglich an die Pins SPK1 und SPK2 angeschlossen. + an SPK2 - an SPK1 eine Verbindung zu GND oder 5V liegt nicht vor. ich wüsste zumindest nicht wie

Amondian

Das einzige was ich noch verändern könnte, ist das Modul nur mit den 3.3 V lafen zu lassen, aber da der ja auch laut Datenblatt mit 5 V laufen kann (und der Arduino ja meist etwas weniger als 5 ausspuckt) sollte das ja an sich kein Problem sein. Ich schau mal, ob ich ein vernünftiges Foto oder eine Zeichnung der ganzen Schaltung machen kann. Vielleicht liegt der Fehler auch irgendwo anders.

HotSystems

Das einzige was ich noch verändern könnte, ist das Modul nur mit den 3.3 V lafen zu lassen, aber da der ja auch laut Datenblatt mit 5 V laufen kann (und der Arduino ja meist etwas weniger als 5 ausspuckt) sollte das ja an sich kein Problem sein. Ich schau mal, ob ich ein vernünftiges Foto oder eine Zeichnung der ganzen Schaltung machen kann. Vielleicht liegt der Fehler auch irgendwo anders.
Also 5 Volt ist ok, darf nur nicht höher sein.
Allerdings bekommst du Störungen, wenn du die 5 Volt direkt vom Arduino nimmst.
Das sollte man möglichst vermeiden.

Meine Projekte haben immer 2 5Volt Regler. Einer für den Arduino und einer für den DFPlayer.
Mag sein das dies recht aufwändig ist, aber ich habe immer eine saubere Spannung am DFPlayer und nie irgendwelche Störungen und Geräusche.
Für ein Projekt (mehrere gleiche Aufbauten) habe ich sogar einen 20Watt-Verstärker dran, auch der war ohne Störungen aus dem Arduino.

Also wenn Störungen, dann 2 eigenständige 5 Volt Versorgungen.


Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)

Amondian

da es ein Projekt auf engstem raum wird, ist eine 2. Stromversorgung im moment nicht machbar. Die störgeräusche sind aber kaum vorhanden und gehen in dem Brummen eh unter. von daher kann ich erstmal damit leben.


Ich frage mich einfach nur, wie ich das Modul (falls es das ist) platt bekommen habe. höchstens ausversehen einen Pin berührt, mit einem Kabel wo Strom drau war oder irgendwo einen Wackelkontackt.

Go Up